Skip to Content

Changing Source on Scheduled WebI Report with Prompt Causing Subsequent Failure

Oct 17, 2017 at 04:17 PM


avatar image

I have a lot of Web Intelligence reports for which I need to change query sources from .UNV universes to .UNX universes. I am doing this one by one from within Web Intelligence (java applet or rich desktop client) as shown in this video...

It works just fine for reports that are not scheduled or are scheduled, but do not take any parameterss. For scheduled reports that do have prompts and take parameters it seems that it forgets the specified value and throws a "no data to fetch ("psEnter Branch Number:": no given values)" error. However, as you can see in the screenshot the value is still listed.

This situation can be fixed if I just update the schedule and pick the proper parameter values again.

Has anyone else encountered this bug? If so, have you found your way around it so the schedules are not broken. I don't have time for an Service Pack upgrade at this time. Right now we are on 4.1 SP06 Patch 4.


6ps3p.png (89.4 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Anish Mahadik Oct 17, 2017 at 05:37 PM

Hi Neol,

This is due to the default values set in the prompt of the report while changing the data source it is not getting that value from new source so either manually select the value or select the default value again in old source and then perform the change source and then check scheduling option.



10 |10000 characters needed characters left characters exceeded