Skip to Content
0

AFP Standards Mode loading forever

Oct 18, 2017 at 02:06 PM

155

avatar image

Hi experts,

we are currently trying to change our SAP Netweaver Enterprise Portal to use the Standards Ajax Framework Page, since we are getting some problems with the currently used framework regarding the Quirks vs. Standards rendering mode.

To switch to Standards AFP, we created a copy from the following object: Content Administration -> Portal Content Management -> Portal Content -> Portal Users -> Standard Portal Users -> Ajax Standards Mode Framework -> Ajax Standards Mode Framework Page and pasted it as deltalink into a custom folder.

We then created a new portal desktop and configured it to use the new created copy of the Standards AFP and our portal theme (which is customized but based on SAP Tradeshow).

Finally, we changed the Master Rule Collection under System Administration -> portal Display -> Desktops & Display Rules -> Portal Content -> Portal Administrators -> Super Administrators so that our new desktop is available under the URL ../portal/default so that the "old" Framework Page / Desktop is still available under the URL ../portal.

While the "old" desktop is still working fine, the new one using the Standards AFP won't work. When I open the URL /portal/default and login with my credentials (admin rights), I only see a loading/splash screen.This will load "forever" - I closed the window after more than half an hour waiting.

I attached a screenshot from the loading screen - but I guess you won't find any helpful information in this screenshot.

Any tips on how to get the Standards AFP working? I would appreciate any help.

Thanks in advance,
Marius

loading.png (139.8 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Best Answer
Nick Rankin
Oct 21, 2017 at 02:21 PM
0

Hi Marius,

Please run a PCD Inconsistency check as per Note 2225655. PCD inconsistencies can cause the FWP to hang on loading. Please backup your DB before repairing the PCD!

Best regards,

Nick

Show 4 Share
10 |10000 characters needed characters left characters exceeded

Hi Nick,

we did run a PCD inconsistency check. We found some PCD inconsistencies and repaired them as described in the note you mentioned - however, it didn't resolve our issue.

Do you have another idea?

Regards,

Marius

0

Hi Marius,

Call logwatch via:

http://host:port/irj/servlet/prt/portal/prtroot/com.sap.tc~ep~common~logWatch.LogWatchView

Add ALL LOCATIONS for ERROR severity and start recording while reproducing the error. Is anything showing in the traces? Stop the recording after issue reproduced so see the exceptions generated in this time,

Best regards,

Nick

0

Hi Nick,

the trace shows me 2 exceptions generated:

  1. InconsistentUpdateException: Transaction cache is outdated for object 0xAC66A2D3D45961828652248188A7463FE9D7266B. name:rrj9BweffJj58)snqjQTtD2EKg~(2 times)
  2. Cannot convert \\<server name>\sapmnt\<SYSID>\SYS\global\config\cm/etc to an IP adress (3 times.)

Is there a way to check which object is mentioned in the first message? I checked the AFP desktop and framework page to see if I find these strings in their properties but this was not successful.

Regards,

Marius

0

Hi Marius,

I suggest restarting the java engine, rerunning the PCD Check and do the check maybe 2 or 3 times. The errors seem to be pointing to inconsistencies in your PCD at this point.

It may also be an issue with a role object, so you should also run a UME Consistency check and repair also (Note 1016283)

Best regards,

Nick

0
Marius Margraf Oct 19, 2017 at 06:46 AM
0

Hi John,

we are running the portal in version 7.4.

Our costum theme was build with/for the old Theme Editor. During the attemps to make the Standards AFP work, we already activated the UI Theme Designer. We exported the costum theme first, activated UI Theme Designer and then imported it. I then made some little changes in our theme because some images were not displayed correctly. After this, our costum theme works fine with the old desktop / Framework Page.

I also switched the theme in the new Desktop with the Standards AFP to a default SAP theme to check if the theme is the issue - I'm still getting the loading screen forever.

Regards,

Marius

Show 4 Share
10 |10000 characters needed characters left characters exceeded

Did you try restarting your portal after activating the UI Theme Designer? I vaguely recall having some issues with it in 7.4 that a restart seemed to fix.

It sounds like you have done the right things in terms of the theme, might be time to log a support call.

Regards,

John

PS - I would probably put a standard theme in your desktop before SAP look at it, just to take the custom theme out of the equation as being a potential cause.....

0

Hi John,

yes, we did a restart - after working with SAP software for a few years we learned that a restart often solves your problems ;)

Thanks for your help - I guess I will contact SAP with this issue. I'll make a reminder for myself to update this thread with the solution once we found it.

Thanks for your help & advice.

Regards,

Marius

0

Hello Marius,

We are having exactly this same problem. Were you ever able to solve it? Would greatly appreciate any info you could pass along.

Thanks and regards,

John

0

Hi John - unfortunately not. Still working on it...

0
John Draper Oct 19, 2017 at 04:31 AM
0

G'day Marius,

What version of the portal are you running?

Also, are you using the old Theme Editor or the newer UI Theme Designer? Depending on the version, I suspect your custom theme might be the issue.

Regards,

John

Share
10 |10000 characters needed characters left characters exceeded
Marius Margraf Jun 01 at 01:32 PM
0

Hello guys,

we are still working on this issue (incident with SAP is open). I just wanted to update this thread, maybe someone has an answer or this will at least provide some informationen if someone finds it who has the same / similar problems.

We don't have a solution yet, but we think we found out that the issue only exists with users who were created bevor our last release upgrade to NW 7.4. Newer users won't face the issue and are able to access any AJAX Framework Page. Even if we copy an old user, the user copy won't face the issue. We did a PCD and UME inconsistency check and repair, but the issue still exists.

Regards,

Marius

Share
10 |10000 characters needed characters left characters exceeded
Marius Margraf Jun 08 at 02:14 PM
0

Hello,

we did a PCD check again and somehow now this resolved the issue. This means that Nick was actually right, but somehow the error wasn't fixed the first time.

Regards,

Marius

Share
10 |10000 characters needed characters left characters exceeded