Skip to Content
0

BPC 11 - WebClient hangs while accessing environments

Oct 18, 2017 at 07:41 AM

764

avatar image
Former Member

We recently installed BPC 11 on our BW/4HANA system. Although we followed the installation steps described in the guide we have a problem with the webclient. When starting the BPC4WEBCLIENT it stops at the point "Check if environment is accessible".

We've checked the browser console and found that a javascript service cannot be loaded:

Here's our system configuration:

Any help or suggestions are welcome. Thanks in advance.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

10 Answers

Best Answer
William Yu
Nov 01, 2017 at 01:01 AM
0

Hi all,

Seems this will only happen for new user initial logon when there is no default environment to connect.

Before SP03, please try this workaround, (user shall be already authorized to this environment)

For logon to standard environment: http://<server>:<port>/sap/epm/bpc/web/index.html#/classic/<environment_name>/home

For logon to embedded environment: http://<server>:<port>/sap/epm/bpc/web/index.html#/pak/<environment_name>/home

After initial logon, user should have no problem to switch to other environments further on.

Let me know if it's working for you.

Best regards, William

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi William,

many thanks for your hints, which lead me to our root problem.

In our Installation the ENVIRONMENTSHELL was not successfully installed. UJA_APPL table was empty, so I had to reinstall via the steps described in SAP Note 1828767. After reinstalling / reparing the ENVIRONMENTSHELL I was able to login via the link patterns you provided. This allowed me to create a new embedded environment, which finally fixed this issue.

Many Thanks,

Stefan

0
avatar image
Former Member Oct 31, 2017 at 05:52 PM
1

Please take a look of this note:

2556575 - BPC web client logon issue - SAP BPC 11.0 BW/4HANA

Resolution

Upgrade to BPC4HANA 100 SP03

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Oct 19, 2017 at 08:28 AM
0

Thanks for your replies.

We've tried all of the supported Browsers with the same result.

It stops at the point "Check if envrionment is assessible"


Share
10 |10000 characters needed characters left characters exceeded
Selva AM Oct 18, 2017 at 02:57 PM
0

Hi Stefan,

It might be a IE compatibility issue. In Internet Explorer Settings, go to Compatibility View Settings and add the website. Hope this helps you.

-- Selva.

Share
10 |10000 characters needed characters left characters exceeded
Yogesh Patel
Oct 18, 2017 at 03:45 PM
0

Can you please try Firefox and let me know. As per PAM below browsers are supported

Ref: https://support.sap.com/content/dam/launchpad/en_us/pam/pam-essentials/BPC11_4_HANA.pdf

Thank you

Yogesh


Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Oct 23, 2017 at 01:10 PM
0

Hello Stefan, Waldemar,

Currently i am having the same issue.

I just build a new system including all latest availbale paches and also HANA 2.0 SPS2.

I found out that actually there are 2 slashes in the url and when debugging the BSP in SE80 i found out that between the slashes there should be the word "classic" or "pak" added (don't know where and how yet)

then the url is complete according to the ABAP BSP code and path in SE80.

i have created an SAP ticket and hope they will find the solution soon.

could be some customzing is missing or SAP did not add the variable in the URL.

Regards,

Robert.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Oct 23, 2017 at 06:53 AM
0

Hi Stefan,

did you fix this problem. I face the same issue and system configuration/version is exactly the same.

Regards

Waldemar

Show 1 Share
10 |10000 characters needed characters left characters exceeded

I have exactly the same issue as described here. Does anybody know already the answer to fix this ?

Regards

Nico

0
avatar image
Former Member Oct 31, 2017 at 05:51 PM
0

Hi. I have exactly the same problem.

Today, SAP published note 2556575. This indicates updating the BPC4HANA 100 component to SP03. This download medium has not been there yet.

I opened a message to SAP for the BPC4HANA 100 SP03 medium request.

Regards

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Nov 01, 2017 at 08:18 PM
0

Hi William,

It works now! after doing the assignation role for the environment in SU01.

and proceding with your instructions.

Thank you so much!

Diego

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Diego ,

Please which role have you assigned to your user ? because i'm facing the same problem here .

thank you

0
Former Member

Hello Fatima,

Did you find the Role in SU01?

I have the same issue.

Thanks in advance.

Regards.

0
avatar image
Former Member Nov 27, 2017 at 09:36 PM
0

Hi All,

For the above issue Please find the workaround

Workaround:

  • For logon to standard environment use this template URL: http://<server>:<port>/sap/epm/bpc/web/index.html#/classic/<environment_name>/home
  • For logon to embedded environment use this template : URL: http://<server>:<port>/sap/epm/bpc/web/index.html#/pak/<environment_name>/home

--Thanks

Aneesh

Share
10 |10000 characters needed characters left characters exceeded