Skip to Content
0

Fiori Launchpad Apps not appearing On Premise Hana

Oct 18, 2017 at 07:12 AM

194

avatar image

After deploying the sample Fiori Launchpad module to XS Advanced, then going to the FLP url. No sample apps appear on the dashboard as in the instructional video. here is the developer tools error from chrome:

Failed to load resource: the server responded with a status of 404 (Not Found)
send @ jquery-dbg.js:9203
core-min-0.js:92 2017-10-18 15:04:54.316405 failed to load 'sap/ushell/adapters/cf/library-preload' (failed to load 'sap/ushell/adapters/cf/library-preload.js' from /resources/sap/ushell/adapters/cf/library-preload.js: 404 - Not Found) - 
K @ core-min-0.js:92
core-min-0.js Failed to load resource: the server responded with a status of 404 (Not Found)
send @ jquery-dbg.js:9203
core-min-0.js:92 2017-10-18 15:04:54.709754 failed to load 'sap/ushell/cloudServices/interceptor/library-preload' (failed to load 'sap/ushell/cloudServices/interceptor/library-preload.js' from /resources/sap/ushell/cloudServices/interceptor/library-preload.js: 404 - Not Found) - 
K @ core-min-0.js:92
core-min-0.js:92 2017-10-18 15:04:54.965774 registerResourcePath ('sap/ushell/services/cdm/NavTargetResolution', '/ushell/services/cdm/NavTargetResolution/') -  sap.ui.ModuleSystem
core-min-0.js:92 2017-10-18 15:04:54.966379 registerResourcePath ('sap/ushell/personalization', '/ushell/personalization/') -  sap.ui.ModuleSystem
core-min-0.js:92 2017-10-18 15:04:54.966604 registerResourcePath ('apps', '/apps/') -  sap.ui.ModuleSystem
core-min-0.js:92 2017-10-18 15:04:56.997754 registerResourcePath ('sap/ushell/components/flp', 'https://flp.convergencect.us:51035/resources/sap/ushell/components/flp/') -  sap.ui.ModuleSystem
xhr.js?eval:1 GET https://fqdn:51006/sap/es/ina/GetServerInfo?_=1508310293700 404 (Not Found)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Matthew Wong Oct 18, 2017 at 07:13 AM
0
Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member
Jan 11 at 11:14 AM
0

HI Matthew,

Did you finally found the solution to this?


Regards,

nitin

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Yes, there a two solutions, one being installing a correct version of Hana express, the other is a command line option when deploying your mta.yaml

but the latest version of hana express i downloaded on Dec 22 2017 seemed to still have this error. my colleague downloaded a HANA express version on Dec 11 2017 which had no problem building and deploying the fiori launchpad. so i am not sure why I'm getting problems on an even later release of hana express.

0