Skip to Content

yMkt geospatial map counts roots instead of facets

Oct 16, 2017 at 07:07 PM


avatar image

Dear Community,

we are using in hybris marketing on-prem a segmentation-model that is based on an attribute view with a relation from the root-table to the facet-table. The relation to the facet-table is needed to make some filtering on facet-data.

Longitude and latitude are activated on the root table (not on the facet table). When we now display our customers on a spatialmap, all facets of a customer are counted – and not only the root entries. E.g. one customer (root) with three facets is displayed on the map as “3” instead of “1”.

How can we change this, so that only customers and not facets are counted?
Can we change the spatial map, so that it only counts customers (roots)?
Can we use attribute view for this?

Thank you,
Best regards,

10 |10000 characters needed characters left characters exceeded

Hi Peter,

I need to do the geospatial segmentation for the customers we migrated from s/4.For those customers there were no latitude and longitude data maintained in the Root table.I manually maintained the data in the root table .I enabled the attributes for the segmentation object and cross verified that the longitude is marked as GEOPT and have latitude as dependent attribute.Both longitude and latitude are defined as decimal in the segmentation object.Still i am not able to see any customers over the "here maps" while doing geospatial segmentation.

Please let me know if i have missed anything .You have mentioned that "Longitude and latitude are activated on the root table",Is this something needs to be done ?Is there any specific format of the latitude and longitude ?

Below is link i have also posted in the forum

Thanks in Advance.



* Please Login or Register to Answer, Follow or Comment.

1 Answer

Peter Meier Oct 17, 2017 at 08:29 AM

Dear Rashmi,

the Segmentation and the geospatial display works fine, as long as we do not filter on ID_ORIGIN on the facet-table.

E.g. a customer with two facets (and without any filtering) is displayed correctly on the map as one single dot. When we now filter on ID_ORIGIN either in SPRO > “Define Segmentation Profiles” > Filter or in HANA Attribute View the one single dot from before is now displayed as a dot with the number “2” in it.

How can we filter on ID_ORIGIN without splitting up the customers in facets on the map?

Best regards,

10 |10000 characters needed characters left characters exceeded