Skip to Content
0

Adapter Specific Identifier gets blank

Oct 16, 2017 at 05:56 PM

78

avatar image

Hi SAPiens,

Whenever we transport ID objects for SAP_ECC system from DEV to QA OR PROD, all messages related to ECC system fails..... Upon checking it was observe that we every new transported objects to ID, SAP_ECC system showing blank values for Adapter Specific Identifier... and we are getting it from SLD by editing business system in ID...

Why its getting blank every time?

BR,

Rashmi

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Raghuraman S Oct 17, 2017 at 03:31 PM
1

Hello Rashmi,

Were the logical system name details present in transport targets of BS in SLD?

Show 9 Share
10 |10000 characters needed characters left characters exceeded

Hi Raghu,

We have same business system and logical names in SLD for DEV QA and PROD, hence we dont have anything in transport tabs.

Regards,

Rashmi

0

That's interesting. Same for all three environments?

So in you case I guess you need to manually import from SLD the BS or do a sync in ID after you move the transport first time as there wont be any link between BS when you transport.

0

Yeah, all DEV QA and PROD having separate SLD, when I see business system in DEV/QA, I dont see anything in Transport Tab...

Can you tell me how to map BS here?

BR,

Rashmi

0

In your case you have Decentralized SLD which is specific for each environment , but you can create all three BS Dev,Qa and Prod in your Dev SLD and then set the transport path accordingly . So when you are moving objects to QA or Prod you can actually import the SLD content from Dev environment and import it in QA or Prod accordingly.

0

You can check the below link on how to maintain transport targets

https://blogs.sap.com/2011/02/21/transport-targets-and-groups-in-the-sld/

0

So basically I will have to create DEV QA and PROD BS in SLD of DEV QA AND PROD???

BR,

Rashmi

0

Yes, If its not decentralized SLD.

And maintain transport targets.

0

Ok may be thats why everytime I transport ID objects to QA or PROD I have to refresh Adapter Specific Identifiers as well....

I will check this with basis....

Thanks!!

BR,

Rashmi

0

Yep..Could be..

Please check and let us know if this solves your issue.

0
Manoj K Oct 24, 2017 at 02:32 PM
1

Step 1: Create Dev BS , QA BS and Prod BS in Dev SLD.

Step 2 : Set the Transport path in Dev SLD accordingly using the link shared by Raghu.

Step 3 : Export all the newly created BS from Dev SLD. and Import the same in QA SLD and Prod SLD.

Step 4: Then finally import your ID objects to QA and Prod.

Br,

Manoj

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Awesome, thats for sharing it pointwise... easy to talk to basis folks now... Thanks!!

BR,

Rashmi

0
Mate Moricz
Oct 17, 2017 at 04:30 PM
0

HI Rashmi,


The Adapter specific identifiers are not automatically populated. You have to manually synchronize them, that's why you see it as empty after transport.

This is also documented: https://help.sap.com/viewer/d0a0a7cb51dc40529bfcac724dd05796/7.5.6/en-US/3feadbbd0c2f471cb2ed41d86dbb63be.html

Best regards,
Mate

Show 3 Share
10 |10000 characters needed characters left characters exceeded

This is only true when someone change the Logical system in SLD , but when it is not changed it should be read whatever it was earlier .

@Rashmi : Check if the Dev / QA system are assigned to correct Integration server and you have proper logical system defined to each of them in SLD if you are decantralized SLD make sure that respective Integration Server/Logical System/Business system are there in all SLD instance.

0

Hi,

In my experience and what I have seen in several system, this has to be done always.

Best regards,
Mate

0

The below is from the link which you shared :

If the adapter-specific identifiers for a business system change in the SLD, this information is not automatically updated in the Integration Directory. To synchronize the information in the Integration Directory with the SLD, choose Comparing with System Landscape Directory in the window forEditing Adapter-Specific Identifiers . This function is only available for business system components.
0