Skip to Content
0

System copy import having issues

Oct 16, 2017 at 09:55 AM

114

avatar image
Former Member

I am attaching the corresponding trans.log file ,please go through once.

I am having an issue in R3trans -d ,return 008,but R3trans -x return 000.

Please check below.

Working on Heterogeneous System copy.

sapdev:devadm 62> cat trans.log

4 ETW000 R3trans version 6.24 (release 721 - 19.10.16 - 20:16:07).
4 ETW000 unicode enabled version
4 ETW000 ===============================================
4 ETW000
4 ETW000 date&time : 11.10.2017 - 13:03:41
4 ETW000 control file: <no ctrlfile>
4 ETW000 R3trans was called as follows: R3trans -d
4 ETW000 trace at level 1 opened for a given file pointer
4 ETW000 [ dev trc,00000] Wed Oct 11 13:03:41 2017
4 ETW000 [ dev trc,00000] Loading DB library '/usr/sap/DEV/SYS/exe/run/dboraslib.so' ...
4 ETW000 [ dev trc,00000] Library '/usr/sap/DEV/SYS/exe/run/dboraslib.so' loaded
4 ETW000 [ dev trc,00000] Version of '/usr/sap/DEV/SYS/exe/run/dboraslib.so' is "721.02", patc hlevel (0.801)
4 ETW000 [ dev trc,00000] dbs/ora/stmt_cache_size = 250
4 ETW000 [ dev trc,00000] Register application info.
4 ETW000 [ dev trc,00000] Oracle client version: 11.2.0.4.0, V3, default build, (dbsl 721 2909 16, UNICODE[2])
4 ETW000 [ dev trc,00000] Installed Oracle client patches:
4 ETW000 [ dev trc,00000] # Patch 19852360 : Created on 20 Oct 2014, 08:17:43 hrs PST8PDT
4 ETW000 [ dev trc,00000] # Patch 12985200 : Created on 2 Jul 2014, 09:45:20 hrs PST8PDT
4 ETW000 [ dev trc,00000] # Patch 11742262 : Created on 6 Nov 2013, 15:22:08 hrs CET
4 ETW000 [ dev trc,00000] Client NLS setting (by OCINlsGetInfo(con=0)): 'AMERICAN_AMERICA.UTF1 6'
4 ETW000 [ dev trc,00000] Logon as OPS$-user to get SAPSR3's password
4 ETW000 [ dev trc,00000] Connecting as /@DEV on connection 0 (nls 0) ... (dbsl 721 290916, UN ICODE[2])
4 ETW000 [ dev trc,00000] OCIHandleAlloc(con=0): Service svc=389d438 created, rc=0
4 ETW000 [ dev trc,00000] OCIServerAttach(con=0, svc=389d438): New server hdl. srv=389fca0 att ached to 'DEV'
4 ETW000 [ dev trc,00000] OCISessionBegin(con=0, svc=389d438, srv=389fca0='DEV'): start sessio n usr=38ce9b0='/', rc=0
4 ETW000 [ dev trc,00000] Now '/@DEV' is connected: con=0, nls=0, session=528, time='2017-10-1 1 13:03:41'
4 ETW000 [ dev trc,00000] Got SAPSR3's password from OPS$-user
4 ETW000 [ dev trc,00000] Disconnecting con=0
4 ETW000 [ dev trc,00000] OCISessionEnd(con=0, svc=389d438, srv=389fca0='DEV'): Close session usr=38ce9b0, rc=0
4 ETW000 [ dev trc,00000] Connecting as SAPSR3/<pwd>@DEV on connection 0 (nls 0) ... (dbsl 721 290916, UNICODE[2])
4 ETW000 [ dev trc,00000] OCISessionBegin(con=0, svc=389d438, srv=389fca0='DEV'): start sessio n usr=38ce9b0='SAPSR3', rc=0
4 ETW000 [ dev trc,00000] Now 'SAPSR3/<pwd>@DEV' is connected: con=0, nls=0, session=528, time ='2017-10-11 13:03:41'
4 ETW000 [ dev trc,00000] DB instance DEV is running on sapdev with ORACLE version 10.2.0.1.0 since OCT 11, 2017, 13:02:59.
4 ETW000 [ dev trc,00000] con=0, V$NLS_PARAMETERS: NLS_LANG=AMERICAN_AMERICA.UTF8, NLS_NCHAR=U TF8
4 ETW000 [ dev trc,00000] # CharacterSet NCharSet envhp errhp er2hp bathp
4 ETW000 [ dev trc,00000] 0 UTF16 AL16UTF16 38900d0 389b41 8 389c498 389d518
4 ETW000 [ dev trc,00000] Connection 0 opened (DBSL handle 0)
4 ETW000 [ dev trc,00000] DbSlControl(DBSL_CMD_SAPRELEASE_SET,abap='701')
4 ETW000 [ dev trc,00000] NTAB: version is VERS_B, UNICODELG=2, SAP_UC_LN=2
4 ETW000 [ dev trc,00000] check2: OCIStmtExecute() failed with -1=OCI_ERROR
4 ETW000 [ dev trc,00000] SQL error 942:
4 ETW000 [ dev trc,00000] statement for table 'TADIR ':
4 ETW000 [ dev trc,00000] SELECT * FROM "TADIR" WHERE "PGMID"=:A0 AND "OBJECT"=:A1 AND "OBJ_NAME"=:A2
4 ETW000 [ dev trc,00000] stmt_fetch() -> orc=942, 103=DBSL_ERR_DBOBJECT_UNKNOWN
4 ETW000 [ dbtrtab ,00000] ***LOG BZA=>table TADIR does not exist on d atabase
4 ETW000
2EETW000 I have some problems during TADIR access.
4 ETW000 Connected to DBMS = ORACLE --- dbs_ora_tnsname = 'DEV' --- SYSTEM = '???'.
3WETW000 The HEAD entry in TADIR is missing.
4 ETW000 [ dev trc,00000] check2: OCIStmtExecute() failed with -1=OCI_ERROR
4 ETW000 [ dev trc,00000] SQL error 942:
4 ETW000 [ dev trc,00000] statement for table 'PATCHHIST ':
4 ETW000 [ dev trc,00000] INSERT INTO "PATCHHIST" VALUES(:A0,:A1,:A2,:A3,:A4,:A5,:A6,:A 7)
4 ETW000 [ dev trc,00000] stmt_execute() -> orc=942 (orc1=942), rc=103=DBSL_ERR_DBOBJECT_UN KNOWN
4 ETW000 [ dbtrtab ,00000] ***LOG BZA=>table PATCHHIST does not exist on d atabase
4 ETW690 COMMIT "0" "0"
4 ETW000 trace to file pointer closed
4 ETW000 trace at level 1 opened for a given file pointer
4 ETW000
4 ETW000 ================== STEP 1 =====================
4 ETW000 date&time : 11.10.2017 - 13:03:41
4 ETW000 function : CONNECT
4 ETW000 buffersync : YES
4 ETW000 clients : default
4 ETW000 l.s.m. : VECTOR
4 ETW000 commit : 100000
4 ETW000 table cache : dynamic
4 ETW000
4 ETW000 [ dev trc,00000] Disconnecting from ALL connections:
4 ETW000 [ dev trc,00000] dbcon[db_con_disconnect_all]: disconnecting from connection 0 ...
4 ETW000 [ dev trc,00000] Disconnecting con=0
4 ETW000 [ dev trc,00000] OCISessionEnd(con=0, svc=389d438, srv=389fca0='DEV'): Close session usr=38ce9b0, rc=0
4 ETW000 [ dev trc,00000] OCIServerDetach(stale1 con=0, svc=389d438, srv=389fca0='DEV') succes sfully detached
4 ETW000 [ dev trc,00000] OCIHandleFree(con=0, svc=389d438): Server handle srv=389fca0 freed
4 ETW000 [ dev trc,00000] OCIHandleFree(con=0): Service hdl. svc=389d438 freed.
4 ETW000 [ dev trc,00000] dbcon[db_con_disconnect_all]: disconnected from connection 0
4 ETW000 [ dev trc,00000] statistics db_con_commit (com_total=1, com_tx=1)
4 ETW000 [ dev trc,00000] statistics db_con_rollback (roll_total=0, roll_tx=0)
4 ETW000 Disconnected from database.
4 ETW000 End of Transport (0008).
4 ETW000 date&time: 11.10.2017 - 13:03:41
4 ETW000 1 warning occured.
4 ETW000 1 error occured.
==================================================================================================
sapdev:devadm 63>
sapdev:devadm 63> R3trans -d
This is R3trans version 6.24 (release 721 - 19.10.16 - 20:16:07).
unicode enabled version
2EETW000 I have some problems during TADIR access.
R3trans finished (0008).
sapdev:devadm 64> R3trans -x
This is R3trans version 6.24 (release 721 - 19.10.16 - 20:16:07).
unicode enabled version
R3trans finished (0000).

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

James Zhang
Oct 17, 2017 at 08:34 AM
0

Hi,

DB connection works fine, the root cause is SAPSR3 database user cannot find TADIR, etc.

Could you please check whether TADIR is in database or not?

select owner, object_name from dba_objects where object_name='TADIR'

Best regards,
James

Share
10 |10000 characters needed characters left characters exceeded
Hans-Hendrik Weise
Oct 18, 2017 at 11:03 AM
0

Hello,

R3trans -x tests against an empty database whereas you use
R3trans -d to test against a filled database (so, after the import has completed).
The results you mention are plausible, depending at what stage of the
system copy you are.

Hendrik

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Nov 04, 2017 at 04:48 AM
0

Thanks for your answers ,I have successfully done my OS/DB migration from HP-UX to Suse Linux86_64

Thanks again

Share
10 |10000 characters needed characters left characters exceeded