Skip to Content
author's profile photo Former Member
Former Member

Synchronous Messages don't appear in Runtime WorkBench

Hi all,

We have a senario with ABAP -> XI -> HTTP synchronously, and we found no message in our runtime workbench even after the receiver had gotten the message.

Is there a switch to control whether synchronous message should be log in the adapter engine?

Thanks,

YiNing

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Dec 05, 2007 at 09:46 AM

    You can only see the response from HTTP in the SXMB_MONI.

    Because this adapter does not reside in the Java Stack or in the Adatper J2EE Engine. It is just a service provided by SAP in XI.

    Also to see the responce in the MONI for synchronous you have to make a TraceLevel upto 3 in SXMB_ADM--Integration Engine Configuration.

    Thanks

    Farooq.

    Add a comment
    10|10000 characters needed characters exceeded

    • I think there should nt be anymore confusion on this thread.

      <i>Hi Farooq, do you mean the receiver http adapter is not a part of Adapter Framework?</i>

      Yes. HTTP adapter lies directly on the Integration Server, the ABAP stack, and is not a part of Adapter Engine (the java stack).

      So u ll not be able to see that message in RWB

      Regards,

      Prateek

  • Posted on Dec 05, 2007 at 09:39 AM

    Hi YiNing,

    RTW is part of the Java stack, you see only messages, which came along Java adapters. ABAP (is this a proxy?) and http are native adapters of WAS, so you can see the messages only at SXMB_MONI.

    Regards,

    Udo

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 05, 2007 at 09:49 AM

    Hi Mao,

    Yes , You need to switch on some settings in Integration engine to see the syncronous messages.

    Go to SXMB_ADM -> Integration engine configuration -> Edit-> Change specific configuration data in the table you need add a new entry -

    Category Runtime

    Parameters LOGGING_SYNC

    Current value should be 1

    Add this entry and save the configuration then all the Sync messages get logged.

    Cheers,

    Nanda

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      After changing the LOGGING_SYNC value to 1 the messages start logging but ¿How the LOG space is maintain to avoid it grows to high? ¿is a BASIS task or is an automatic TASK in the PI server?

  • author's profile photo Former Member
    Former Member
    Posted on Jan 23, 2014 at 06:11 PM

    After changing the LOGGING_SYNC value to 1 the messages it will start logging but ¿How the LOG space is maintain to avoid it grows to high? ¿is a BASIS task or is an automatic TASK in the PI server?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.