Skip to Content

Communication Channel Monitoring Empty

Hello everyone,

We have a RFC -> XI -> HTTP scenario. The interface is synchrous.

When executed we get a TCP/IP error saying that the program id is not registered.

BUT the program id is in the rfc sender adapter.

In the Communication Channel Monitoring (RWB > Component Monitoring > Adapter Engine) we can not see any of our adapters. I suspect this is where we are fault.

Any takers?

Thanks,

Dimitris

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Dec 04, 2007 at 12:22 PM

    Hi Dimitris,

    Can you please check a test connection with RFC destination if created in SAP R/3 side?

    Also please check the program ids in RFC destination and communication channel (adapter config) should be same.

    Regards

    Prashant

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 04, 2007 at 12:27 PM

    Hello ,

    You cannot see these any communication channels in this scenario.

    RFC is you wont define any Communication channel.

    For HTTP adapter you wont find any communication channel in RWB.

    To check wether your configuration is correct or not you can do a message monitoring .

    For Sync communication in SXMB_ADM you need to set the specific configuration with LOGGING_SYNC to 1. then you can see more details in message monitoring.

    Check and let us know if u have any more issues.

    Cheers,

    Reddy

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 04, 2007 at 12:44 PM

    Hi,

    The program id is the same.

    The communication channel monitoring should show the adapters and their

    status green, red, yello or grey. It does not.

    Any ideas?

    Dimitris

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Dimitris Hagigeorgiou

      Hi ,

      In your scenario you dont find any entries of your Communication channels ( RFC and HTTP) in RWB -> communication channel monitoring .

      It is a Syncronous communication so you dont find any messages also in RWB -> Message monitoring . For message monitoring you need to set LOGGING_SYNC variable in specific configuration of PI System ( using SXMB_ADM -> Integration Engine configuration).

      Regards,

      Reddy

  • Posted on Dec 04, 2007 at 12:57 PM

    <i>In the Communication Channel Monitoring (RWB > Component Monitoring > Adapter Engine) we can not see any of our adapters.</i>

    Do u mean u r unable to see the communication channels? Inside communication channel monitoring, we see the communication channels. Adapters are seen under the Adapter Monitoring tab.

    Regards,

    Prateek

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.