Skip to Content
0

DBSQL_DUPLICATE_KEY_ERROR on UJBR Restore

Oct 12, 2017 at 03:10 PM

45

avatar image

Hi, experts!

We are on BPC 10.1 NW SP12 / BW 7.4 SP17.

I'm facing an issue trying to import a restore zip file on DEV environment. In context, I've come to know that one user has been modifying and creating reports, scripts and DM Packages directly on PRD so now I want to import all these modifications on DEV so from now on we work on DEV and then transport to PRD. For this I had the idea of using UJBR in PRD to export the appset and then import only the File System it into DEV on the existing appset. When I did that I got an ST22 dump stating DBSQL_DUPLICATE_KEY_ERROR.

You have any idea what this could be or any other way around to accomplish migrating reports, scripts and DMPackages from PRD to DEV?

Thanks!

Best regards,

Joaquín.

ujbr.jpg (79.9 kB)
st22.jpg (126.0 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Vadim Kalinin Oct 12, 2017 at 03:39 PM
0

You have to analyze ST22 log to provide at least some info to help you with your issue...

Show 6 Share
10 |10000 characters needed characters left characters exceeded

Sorry...

It states that if the same register exists on UJF_DOCTREE table when importing, causes this error...

Should I delete the entries? What would be the impact?...

Thanks again!

Best regards,

Joaquín.

st22b.jpg (202.0 kB)
0

Try to experiment yourself... Create a copy of environment in DEV and restore to it (with delete in UJFS).

0

Hi.

Just to let you know, I tested deleting the complete folder from UJFS, checked that there were no registries on UJF_DOC and UJF_DOCTREE tables for the environment I was going to restore, then execute restore on background mode through UJBR with file service option checked.

Every script, report, transformation, etc. is restored. Just noticed that in some reports/input forms the connection was not migrated from PRD to DEV, so those had to be modified manually... don't know why that happened.

Thanks again.

Best regards,

Joaquín.

0

"the connection was not migrated from PRD to DEV" - not clear! What do you mean? May be the connection was saved in the file.

0

Hi,

When I opened the report on DEV that was just restored via UJBR, I noticed that it was still connected to PRD even though it was saved on DEV (it refreshed PRD data). This happened only on a few reports/input forms. Could this report options be the cause? (see attached file).

Best regards,

Joaquín.

report-options.jpg (12.6 kB)
0

Yes, it depends on this option!

0