Skip to Content
avatar image
Former Member

Receiving Exit Code 70 on Silent Install of Business Objects Analysis, Edition for Microsoft Office

When trying to install Business Objects Analysis Edition for Microsoft Office version 2.4+, on a user's Windows 10 machine, using the "/silent" flag, the process exits and fails to install, returning Exit Code 70.

When the user installs without the "/silent" flag (no other flags), the installation is successful.

This only happens on a specific couple of users' machines. On my machine and most others', the installation is successful both with and without the "/silent" flag.

All users have the prerequisites of Microsoft Office 2016 and Microsoft .NET Framework 4.5, as described in this Administrator Guide.

What does Exit Code 70 mean for Analysis, and what steps should I take to resolve this?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Oct 12, 2017 at 09:43 AM

    Hi Sara - I am guessing, but could your users have different SAP Gui versions? See https://wiki.scn.sap.com/wiki/display/Basis/SAP+GUI+Packaging+and+Installation

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Tammy, thanks for your response.

      I will check with my users if they have any version of the SAP Gui installed. However, I know that I personally have been able to install Analysis via direct executable from a distribution medium without having the SAP Gui, and have confirmed with others that the SAP Gui is not required.

      If these users have the SAP Gui installed, I'd rather not have to uninstall it in order to silently install Analysis.

      However, in the document you linked as well as others online, I've seen that running an install with the /silent flag also requires defining the product name or package name. I've also seen information about users not having an installation server set up.

      What would the product or package name be in this instance--is it a generic flag or name, or is it specific to a user's setup? Would I need to configure an installation server if I'm trying to install from a distributed medium?

      UPDATE: Other users with the SAP Gui installed have not had trouble with this Exit Code 70 issue.