Skip to Content
author's profile photo Former Member
Former Member

Error XI XML not well formed

The source XML file includes above field. When I tried to test the message mapping using the source xml file with the above tag.Message mapping resulted in an error "XML is not well formed". Does any body have any idea how to prevent this in XI ?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Posted on Dec 03, 2007 at 09:52 PM

    <LOCATION>México_DF_MX</LOCATION>

    It has nothing to do with above filed. Ther must be some thing else wrong with in the mapping. The above tag successfully executed in one of my mappings.. check if all the tags are properly closed in the source xml.

    VJ

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello Nivedita,

      I had a similar requirement couple of years ago and not much has changed in how we can handle xml containing unwanted special characters. I ended up creating a java bean (ejb) which removed the special character and replaced it with space. Writing a ejb can pose its own challenges but this is a sure way to fix the problem. I used NWDS to code and deployed it as a service to XI engine.

      Let me know if you need any documentation on this...there are plenty of advices and links pdf floating around in SDN.

      Thanks,

      Pam

  • author's profile photo Former Member
    Former Member
    Posted on Dec 03, 2007 at 10:19 PM

    Thanks for the response.

    <?xml version="1.0" encoding="UTF-8" ?>

    I have the encoding option at the top of the xml file but still get the error "XML file not well formed".

    Does this need to be fixed in XI or java ? If this needs to be fixed in XI then how ?

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 03, 2007 at 11:29 PM

    Hello kamath,

    Thanks for the immediate response.

    I tried the encoding option you provided, it resulted in the same error. But I used a similar one "iso-8859-1" with iso prefixed and Message mapping test is successful.

    Your answer was helpful.

    Thanks,

    Nivedita

    Highly appreciate all of your help.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.