Skip to Content
author's profile photo Former Member
Former Member

Starting NW2004s preview on Ubuntu

Hi,

I have installed the NW200s preview on my Ubuntu 7.10 system. But i've problem to start the DB, i receive the following error message :

n4shost:n4sadm 42> pg startdb.log

-


Thu Dec 2 17:52:22 CET 2010

LOGFILE FOR STARTING DATABASE

Trying to start database ...

-


Thu Dec 2 17:52:22 CET 2010

Checking required environment variables

SAPSYSTEMNAME is >N4S<

Start database with xuserkey >c<

-


Thu Dec 2 17:52:22 CET 2010

Connect to the database to check the database state

dbmcli: connect check finished with return code: 0

Database not available

-


Thu Dec 2 17:52:22 CET 2010

Starting XServer

12916 XSERVER Found other running x_server with version 'X64/LINUX 7.6.00 Build 018-123-119-055'

12902 XSERVER started, 'already...'

-


Thu Dec 2 17:52:22 CET 2010

Starting database

Starting Database Instance...

Error! XUser not found!

Opening Database...

Error! XUser not found!

-


Thu Dec 2 17:52:22 CET 2010

Connect to the database to verify the database is now open

dbmcli check finished with return code: 0

Database start failed

Any idee about my problem ?

Kind regards,

Pierre

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on Dec 02, 2007 at 05:09 PM

    check with

    xuser list

    if there are any "shortcuts" for the users created.

    --

    Markus

    Add a comment
    10|10000 characters needed characters exceeded

    • Dear Pierre,

      grep for 'xuser' in the install.sh, and execute the steps again:

      cd /media/dvd
      grep xuser install.sh
      ERR_create_xuser_failed=9
              su -c "/sapdb/programs/bin/xuser -U DEFAULT -u sapn4s,sapn4sadm -d N4S -n n4shost -S SAPR3 -t 0 -I 0 set" -l n4sadm >/dev/null 2>&1
              su -c "/sapdb/programs/bin/xuser -U c -u control,sapn4sadm -d N4S -n n4shost -S SAPR3 -t 0 -I 0 set" -l n4sadm >/dev/null 2>&1
              su -c "/sapdb/programs/bin/xuser -U c_J2EE -u control,sapn4sadm -d N4S -n n4shost -S SAPR3 -t 0 -I 0 set" -l n4sadm >/dev/null 2>&1
              su -c "/sapdb/programs/bin/xuser -U w -u superdba,sapn4sadm -d N4S -n n4shost -S SAPR3 -t 0 -I 0 set" -l n4sadm >/dev/null 2>&1
      

      Just execute the last four commands manually as user root. You may want to remove the '>/dev/null 2>&1' setting so see what is going one there.

      Do you have the compat-libstdc++ package installed? You may need the libstdc++.so.5 for MaxDB to work properly ...

      Thanks,

      Hannes

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.