Skip to Content
0

HANA SPS12 : Multitenant Conversion Failed due to XSA Runtime

Oct 13, 2017 at 02:46 AM

159

avatar image

Hello

Last year, I have installed S4HANA1610. I have chosen to install SAP HANA DB in single tenant mode(what a fool !!!). And now I am trying to convert into Multi-tenant mode to transfer this HANADB tenant into a SAP HANA 2.0 DB tenant.

I have updated the single-tenant HANADB to version 1.00.122.12.1502962396.

But i can not convert into multitenant with this version of XSA as explained in Note 2313789

Any solution ?

Regards

Emmanuel

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Thomas Jung
Oct 17, 2017 at 05:59 PM
0

Why not update the XSA Runtime version first? The XSA runtime is release independent of the HANA database release - meaning you can install the latest HANA 2.0 SPS 02 version of the XSA runtime on your HANA 1.0 SPS 12 system.

Show 7 Share
10 |10000 characters needed characters left characters exceeded

Hello Thomas.

First, thank you for all your job about SAP HANA.

So I will try the following :

1 - Install the latest HANA 2.0 SPS 02 version of the XSA runtime on my HANA 1.0 SPS 12 system HDB

2 - Convert HDB into multi-tenant mode (always on version 1.0 SPS 12 )

3 - Transfer the tenant HDB (version 1.0 SPS 12) using Backup-Recovery to HANA 2.0 SPS02.

In this case, is the tenant HDB upgraded to HANA 2.0 SPS02 automatically ?

Best regards

Emmanuel

0

I'm sorry but I couldn't answer your question about the backup and recovery of the tenant, as I work primarily in the XSA and dev tools space.

0

I would suggest that if you are going to try any back up and restore approach, to have a look at this service note: https://launchpad.support.sap.com/#/notes/2300937

0

Also if you are planning any kind of migration to MDC I would suggest reviewing this note as well: https://launchpad.support.sap.com/#/notes/2483146

0

Thank you for your help.

I will check every information you give me.

Best regards

Emmanuel Da Costa

0

Could you give me the last version number for XSA runtime, please ?

Now I am using 1.00.65 and I am going to install the 1.00.66.

Best regards

Emmanuel

0

1.0.66 is the latest version released on September 28th.

0