Skip to Content

Valuaton and defect class fields

Experts,

Scenario: I have maintained weighting of characteristic at MIC level in QS23 Tcode. Users do not prefer the valuation & defect class fields displayed in QE51N results & record screen as seen below,

Since there can be more functional behavior that can potentially be tied with valuation & defect class fields, i decided to hide these fields, rather than to touch the config for defect class which i am not familiar with. I see that table variant config button which is a feature from SAP to show or hide fields, change column positions etc.. is not working in QE51N Tcode. My attempt to hide these 2 fields using table variant config has not been successful. I see that table variant config button is working perfectly in other Tcodes like VA01. When we maintain table config data, records are created in TCVIEW table. I tried to forcefully add these entries to a Transport from dev system and moved to quality. This does not work which makes me believe that SAP does not allow table config changes in QE51N tcode.

Reason why users want to remove these fields: Assume user maintains weighting characteristic as Critical for MIC 'Nitrogrn, Total' in QS23. User records results in QE51N for this MIC. Assume he enters a value less than lower limit - Defect class populates as Non critical. If he enters a value above upper limit - Defect class auto populates as Critical. This is confusing for the users who should be taking decision based on Weighting of characteristic & not defect class. User looks as defect class as Non critical and incorrectly assumes MIC is non critical.

Is there a safe way to remove or hide defect class from QE51N Tcode? Is this a meaningful ask? Please share your valuable inputs.

BR,

Aspire

valuation.png (36.9 kB)
valuation.png (44.4 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Oct 14, 2017 at 12:10 AM

    Experts,

    As per solution in this link, I made column length as zero, saved table config to make those 2 fields in visible. I am able to hide the fields successfully now.

    Even before i posted this thread, i bumped into that link. Tried it. Somehow i have not performed the activity correctly & wrongly assumed that the solution in the link does not work for me.

    Tried the same again today & its working.

    BR,

    Aspire

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 14, 2017 at 12:12 AM

    For those who are trying this option for the first time, please check this blog It clearly mentions the details steps to perform table setting variant config.

    BR,

    Aspire

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 13, 2017 at 11:31 AM

    Hi,

    It seems authority issue with your ID. Can you contact to security department to check the authority.

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Amarnath,

      Thanks for your reply. I have confirmed that I have necessary authorization. Can you please let me know if you are able to hide those 2 columns in your system.

      First thing that I did is to ensure security auth objects are in place. I am able to hide columns in

      other standard tcodes.

      BR,

      Aspire