Skip to Content
author's profile photo Former Member
Former Member

IDOC outbound port - No service for system X, client Y in Integration Direc

Hi all,

We have a problem when sending an IDOC from ECC to XI to Legacy. At ECC, tx SMQS, we got the error "No service for system SAPEQ0, client 400, in Integration Directory".

I don't know what we need to do in ID to provide this service and solve this error...

Our ECC is configured on SLD as EQ0_400 (Logical name EQ0CLNT400), and the scenario was developed at Integration Directory using EQ0_400.

Debugging standard function that send the IDOC, I found that it ever uses the sender port as "SAP" + SY-SYSID... So I'm confusing, is necessary to configure the system in SLD whith this name "SAPEQ0"?

thanks.

roberti

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Nov 30, 2007 at 12:09 PM

    Do you have the Business System of ECC imported in ID and activated?

    I am not very sure about the naming convention. However it is recommended you have it in the format SAP<SID>. But I have ECC sending IDOCS to XI with different a different naming convention.

    Regards,

    Jai Shankar

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Glad to hear that you got it working.

      >>"Error occurred during back-routing Error in communication channel".

      Can you give some more description about the error?

      Hope you have configured a IDOC receiver communication channel poiting to the ECCwith no reciever agreement attached to it.

      Regards,

      Jai Shankar

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.