Skip to Content
0

Configuring SAP HANA Express Trial Edition not working

Oct 12, 2017 at 07:49 AM

91

avatar image
Former Member

I'm trying to install SAP HANA Express Edition. I am at the final stages.. 2.1.11 as per the installation manual wherein, I have installed the operating system as a virtual machine using VMWAre Workstation 14 Player. It asks me for the log on and password each time I reboot including the first time. This is where things become unclear. It asks if I want to wait for it to config.

If I say yes, it says to wait, seems to start, shows:

StartService
OK
OK
Starting instance using: /usr/sap/HXE/SYS/exe/hdb/sapcontrol -prot NI_HTTP -nr 90 -function StartWait 2700 2

And then does nothing. Not crash, just no progress. What should I do here?

Sometimes, when trying this, it continues, and shows scrambled text on the screen. What should I do here?

I never get a "Congratulations! SAP HANA, express edition 2.0 is configured." as the instructions suggest.

If I skip the config (not preferred), then I get a welcome, and a note that it will contnue the configs later. I prefer to have them setup from the start due to what I'm planning.

Any advice would be appreciated.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Michael Healy
Oct 12, 2017 at 07:59 AM
0

Have you tried Virtual Box?

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

I have not, as VMWare Workstation was recommended by the instructions. I'll explain how that works once I get the opportunity to test it out.

0
Denys van Kempen
Oct 12, 2017 at 09:30 AM
0

Hi Nicholas,

Can you provide some system specifications?

Host machine: RAM, CPU (Windows version)

Guest VM: Allocated RAM

SAP HANA, express edition: what version are you installing? server, or server + applications?

Regards,

Denys / SAP HANA Academy

Subscribe to our YouTube Channel
Join us on LinkedIn
Follow us on Twitter
Github code samples
Facebook
Google+

Show 4 Share
10 |10000 characters needed characters left characters exceeded

Any update on this Nicholas?

0
Former Member

My apologies on not answering sooner. There were unexpected delays here. To answer your questions:

Host machine:

Windows 10 Pro

CPU: 64-bit operating system, x64-based processor

Processor: Intel (R) Core (TM) i5-3230M CPU @ 2.60 GHz 2.60 GHz

RAM: 6 GB (5.86 usable)

VM:

RAM: 3 GB

HANA: SAP HANA 2.0, Express Edition, Server with applications

0

Hi Nicholas,

No problem. I was just curious.

If I understand the output correctly, you have a computer with 6 GB RAM (host) and a VM with 3 GB RAM (guest).

The reason the system does not start is that not enough memory is available.

Minimum requirements for SAP HANA, express edition for the server version is 12 GB / 8 GB (host / guest) and for the server + applications version is 28 GB / 24 GB.

See the table below for the Getting Started Guide.

You might want to try one of the cloud options. Google currently offers $300 credit for trying out their cloud platform (GCP).

For more information, see my blog

Solves your issue?

Thanks,

D

0

Recently, this Sizing Guide was made avaiable for express edition

https://help.sap.com/viewer/9e4243e92f244537b2164a57a405a9fd/2.0.02/en-US

0