Skip to Content

Error: Failed to get data for main-view

Hi,

I have created a custom widget and tried to use RFC (BAPI_EMPLOYEE_GETDATA). But when I run the widget, I get the following error:

'Failed to get data for main-view.

Reason: Error while executing BAPI_EMPLOYEE_GETDATA:

Service provider could not be found: JCO_SERVICE.'

Can anyone help me with this?

Thanks & Regards,

Lohit

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Nov 30, 2007 at 03:14 PM

    hi lohit,

    first step is to check whther your JCO_SERVICE is working properly or not...

    after the widget is executed give the service provider name(JCO_SERVICE) in the widget's preference....

    thanks

    jaideep

    *reward points if helpful...

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.