Skip to Content
author's profile photo Former Member
Former Member

Missing Documents 2LIS_12_VCITM

Hi All,

There are some deliveries missing on BW side which are available in R/3. Has anybody faced same issue? We are using 2lis_12_VCITM to load delivery items in BW and it is set to delta.

When I check the load on BW side for that date, everything is green. I also checked PRD in St22 and Sm37. Did not find any dumps nor any jobs failed.

Any ideas? It is an urgent production issue and the cause needs to be determined.

Thanks for your help,

Payal.

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Nov 30, 2007 at 04:10 AM

    There might be couple of things you might want to look at:

    1. The delivey documents might have been filtered by extractor , may be due some status. Look at the pattern of the docs that are missing..may be "Onhold"..

    2.Check the 0RECORDMODE what it indicates..like 'X',R, D..etc (this might delete the document..)

    3.See the delivery date.. for these..like if all are falling on the same date range.. if you have missed any delta during that date.. or if there was any load issue on that date ,if some one might have happened to set the status to green while it had been loading.. Check your PSA if the data still is retained .. for those dates.. take one delivery document and see how it exists in PSA.. if it has 0RECORDMODE "X" or D..or R ..it would havent got posted.

    4. Check if there are routines , transformations if you are manipulating data on BI side at transfer rules or update rules level.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 30, 2007 at 04:19 AM

    Hi,

    Are you checing records in Cube or DSO??

    If you are chcking it in the cube than chek if these reecods are cancelled or not becasue cancelled records gets deleted from the cube if 0RECORDMODE is mapped to ROCANCEL in the DSO and data is loaded to the cube through an DSO from R/3.

    Have you tried to check the deliveries creation date...may be you have missed the delta of a particular date and this can cause missing all deliveries of a particular creation date.

    There is no reason for BW, not to select the records from delta queue in R/3.

    May be the job in the R/3 to push data to the delta queue would not have run for that....just chek if fior that date you see less number of records or 0 records.

    Hope it helps

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 30, 2007 at 05:11 AM

    Check RSA3 for that data source in R3 side. You will come to know if the delta was pushed to queue by R3 job or not. Of it does not exist in RSA3 then you may go ahead to inqire if the job at R3 side ran for that perticular date or not. But incase the RSA3 shows data but you could not receive it either in PSA or Cube then there is little you can do to correct these data. Only option then perhaps is to initialize . That too if you know the doument numbers missing or range of documents that is missing. Other wise it will be to reniatilize whole things.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.