Skip to Content
0

filtering ALV not working abap

Oct 16, 2017 at 08:00 AM

28

avatar image
Former Member

Hi!,

I have the following code which is not filtering columsn for radio button : btn4 and btn5.For radio buttons btn1 and btn3 is working fineDo you have any ideea why? Cheers

  
Refresh it_filter.
if btn1 = 'X'.
    ls_filter-fieldname = 'COMDEP'.  "Filtru data comanda intre doua date calendaristice pentru Depasit radiobuton "
    ls_filter-tabname = 'LT_JOIN'.
    ls_filter-sign0 = 'I'.
    ls_filter-optio = 'EQ'.
    ls_filter-valuf_int = 'Depasit'.
    APPEND ls_filter TO It_filter.  ELSEIF btn3 = 'X'.
    ls_filter-fieldname = 'COMDEP'.  "Filtru data comanda intre doua date calendaristice pentru Nedepasit radiobuton "
    ls_filter-tabname = 'LT_JOIN'.
    ls_filter-sign0 = 'I'.
    ls_filter-optio = 'EQ'.
    ls_filter-valuf_int = 'Nedepasit'.
    APPEND ls_filter TO It_filter.
  ELSEIF btn4 = 'X'.
    ls_filter-fieldname = 'GMEIN'.  "Comenzi vrac
    ls_filter-tabname = 'LT_JOIN'.
    ls_filter-sign0 = 'I'.
    ls_filter-optio = 'EQ'.
    ls_filter-valuf_int = 'KG'.
    APPEND ls_filter TO It_filter.
  ELSEIF btn5 = 'X'.
    ls_filter-fieldname = 'MEINH'.  "Comenzi bucati
    ls_filter-tabname = 'LT_JOIN'.
    ls_filter-sign0 = 'I'.
    ls_filter-optio = 'EQ'.
    ls_filter-valuf_int = 'BUC'.
    APPEND ls_filter TO It_filter.
  EndIf.
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Mike Pokraka Oct 16, 2017 at 08:13 AM
1

Swap the button conditions around just as a test - i.e. btn5 at the top with btn1 filter. Then you’ll see if it’s the filtering or the buttons.

Else just debug...

Share
10 |10000 characters needed characters left characters exceeded