Skip to Content
author's profile photo Former Member
Former Member

Error while loading Cube from ODS

Hi

I have one tranformation 0fiscper-->0fiscper from ODS to Cube. In ODS there is proper data. But when I run DTP for loading the data into Cube, I get following error.

Error while updating to target CUBE_01 (type INFOCUBE)

<b>Description</b>

Fiscal year variant BP not expected FGV 1

<b>Details</b>

Error Location: Object Type CUBE

Error Location: Object Name CUBE_01

Error Location: Operation Type VAL_SID_CONVERT

Error Location: Operation Name 0FISCPER

Error Severity 100

Original Record: Segment 0001

Original Record: Number 1

can anyone help to resolve it...?

Thanks

Rakesh

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Nov 30, 2007 at 05:05 AM

    Hi,

    Fiscal period would always come with 0FISCVARINAT and therfore you must make sure that it is presen in the same time dimension and is mapped to the source DSO then only you will be able to load the data in the cube( dont leave it empty).

    Thnkas

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi experts..

      Sorry for respoding late.

      I give the complete details...

      Maping is like this.

      datasource--


      > ODS--


      >Cube

      <b>Datasourece -


      >ODS</b>

      there two mapping like this

      BUKRS ---> 0fiscvarnt

      and

      FTRMI -


      DATE_FISCPER( FTRMI, 'K4' )----


      > 0fiscper

      <b>ODS----->CUBE</b>

      0fiscvarnt------>0fiscvarnt

      and

      0fiscper----


      > 0fiscper

      In ODS the fiscper has the proper data and fiscvarnt in all records have the value 03. Now I am getting the above error when loading the data from ODS to Cube.

      Now plz help

      Thanks

      Rakesh

  • author's profile photo Former Member
    Former Member
    Posted on Nov 29, 2007 at 11:06 PM

    Rejesh,

    DO you have 0FISCPER & 0FISCVARNT loading in your DSO and the same existis in the time dimension of the cube?. Becuaes 0FISCVARNT is mandatory and it should get the proper value. make sure all the FISCVARNT are transferred from R3 into BW.

    Hope this helps,

    Alex(Arthur Samson)

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 30, 2007 at 04:58 AM

    Hi Rakesh

    Problem with your transformation between ODS to CUBE.

    I Request you to check the same once again.

    And also check the error message displayed in error stack for DTP.

    Hope this will help you.

    Regards

    Saravanan.ar

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 30, 2007 at 05:00 AM

    Either map Fiscal Variant in the Target to the Source Field or set it as Constant as required.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 30, 2007 at 11:10 AM

    Hi,

    the its an issue with the data records getting loaded.

    just check the table T009 and and see if the value BP is maintained in the table ro not.

    Also see posting period of this bvarinat and then chek the posting period in the data records and see if these are same or not.....check with the R/3 guy of this combination of variant and period is possible or not.

    Thanks

    Ajeet

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.