Skip to Content
0

SWDD Start Condition only evaluates first part of condition and ignores second part

Oct 14, 2016 at 09:06 AM

35

avatar image

Hi guy,

I am having a bit of a problem with a start condition for a workflow.

My requirement is to make to sure the work doesn't start when the following conditions are met:

Purch Org = 2600 AND Vendor = 2139338.

To meet this requirement I have created a start condition that looks like this:

I have tried it both with and without the parenthisis.

I have tested the condition with different test data combinations and I have deduced that it only evaluates the first part, ie. the purch org. No matter what vendor number I use for testing, if it is 2139338 or other, it is the purch org number that decided whether I get a 'True' or 'False' response.

Example:

Purch org = 2500 and vendor = 2139338 - result =True (correct)
Purch org = 2600 and vendor = 2139338 - result = False (correct)
Purch org = 2600 and vendor = 1234567 - result = False (in-correct)
Purch org = 2500 and vendor = 1234567 - result = True (correct)

Do any you have any suggestions as to what I am doing wrong?

I would hate to have to program something when this functionality is apparently available as standard.

Thanks in advance.

Michael.

8ripq.png (11.4 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Anjan Paul Oct 17, 2016 at 09:15 AM
0

Hi,

Instead of using AND , please check with 'OR'.

Share
10 |10000 characters needed characters left characters exceeded