Skip to Content
0

Cannot save an HTML mashup: "Failed to get the partner top folder due to wrong life cycle setting"

Oct 11, 2017 at 03:46 PM

109

avatar image

Hi,

On a recently provisioned C4C tenant, I am attempting to create an HTML Mashup with the ADMINISTRATION01 account.

When I try to save, I receive an error, "Failed to get the partner top folder due to wrong life cycle setting".

I attempted to follow the advice in this thread (https://archive.sap.com/discussions/thread/3768071) that suggests "Switich On/Off Admin Mode in SAP Solution" from SAP Cloud Application Studio, but that menu option is disabled when I log in with the ADMINISTRATION01 user.

What can I do to get past this?

What does this error even mean?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Prasanth Sarma Aryasomayajula
Oct 11, 2017 at 04:21 PM
0

Create HTML mashup without parameters ,save it
Then edit it and add the parameters , save it

Hope this helps.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

This did not work. The mashup does not have any parameters to begin with.

The parameters we have are:

  • Mashup category: Productivity & Tools
  • Port Binding: <empty> [note: I've also tried Web Widget]
  • Mashup Name: MashupName
  • Description: MashupDescription
  • Status: Active
  • Configuration Information
    • Type: HTML
    • Height: 800
  • HTML Code Editor, paste the following in the box: Hi

When I save, I see the same error message.

0
Keshav Harake Oct 11, 2017 at 08:07 PM
0

Hi

Pls try on this

I had the same error and the problem was the user. A PDI user gave this error, after logging on with a non-PDI user I was able to save the mashup.

the PDI user needs to have Administrator rights to create a Mashup, probably it was missing at the time. Admin Mode for a PDI user can be enabled from Cloud Application Studio->Administration->Switch On Admin Mode.

Br,

Keshav

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi,

I attempted to follow the advice in this thread (https://archive.sap.com/discussions/thread/3768071) that suggests "Switich On/Off Admin Mode in SAP Solution" from SAP Cloud Application Studio, but that menu option is disabled when I log in with the ADMINISTRATION01 user.

What is a "PDI user" vs. a "non-PDI user"? I would assume ADMINISTRATION01 is a PDI user, as it has CRM_OPS as a business profile.

0
0

Keshav,

I read that thread and I don't see how it applies in this case. I'm not trying to "use the PDI user to test the solution". I can't even make any changes as the user to start. Is there something specific you are referring to in linking to that thread?

Thank you.

0