Skip to Content
author's profile photo Former Member
Former Member

Problem In SAP 470 Instalation "HP_UX 11.23 IA64"

Dear all.

I'm having 2 "diferent" problems:

1 - The SAPInst Stops in the Step off Create Oracle Database with the following error message:

ERROR 2007-11-26 22:12:02 [iaxxinscbk.cpp:289]

abortInstallation

CJS-00084 SQL statement or script failed.<br>DIAGNOSIS: Error message: ORA-12547: TNS:lost contact

/usr/lib/hpux64/dld.so: Unable to find library 'libodm9.so'.

/usr/lib/hpux64/dld.so: Unable to find library 'libodm9.so'.

ORA-12547: TNS:lost contact

.<br>SOLUTION: See ora_sql_results.log and the Oracle documentation for details.

2 - When execut the command "make -f ins_rdbms.mk install" i'm getting the following error:

chmod 755 /oracle/DC1/920_64/bin

rm -f oracle mig dbv tstshm maxmem orapwd dbfsize cursize genoci extproc extproc32 hsalloci hsots hsdepxa dgmgrl dumpsga mapsga osh sbttest imp exp sqlldr rman avmurout avmping avligmsg avmumon nid /oracle/DC1/920_64/rdbms/lib/ksms.s /oracle/DC1/920_64/rdbms/lib/ksms.o

- Linking Oracle

rm -f /oracle/DC1/920_64/rdbms/lib/oracle

cc DD64 -Wl,s -Wl,+n +DD64 -o /oracle/DC1/920_64/rdbms/lib/oracle -L/oracle/DC1/920_64/rdbms/lib/ -L/oracle/DC1/920_64/lib/ `if /usr/bin/getconf KERNEL_BITS | grep "64" > /dev/null ; \

then echo "-Wl,pi,16M -Wl,pd,L -Wl,padtext,16M -Wl,paddata,1M" ; \

else echo "" ; fi` -Wl,-E -Wl,-PF,linkorderfile +FPd /oracle/DC1/920_64/rdbms/lib/opimai.o /oracle/DC1/920_64/rdbms/lib/ssoraed.o /oracle/DC1/920_64/rdbms/lib/ttcsoi.o /oracle/DC1/920_64/lib/nautab.o /oracle/DC1/920_64/lib/naeet.o /oracle/DC1/920_64/lib/naect.o /oracle/DC1/920_64/lib/naedhs.o /oracle/DC1/920_64/rdbms/lib/config.o -lserver9 -lodm9 -lskgxp9 -lskgxn9 -lclient9 -lvsn9 -lwtcserver9 -lcommon9 -lgeneric9 /oracle/DC1/920_64/rdbms/lib/defopt.o -lknlopt `if /usr/ccs/bin/ar tv /oracle/DC1/920_64/rdbms/lib/libknlopt.a | grep xsyeolap.o > /dev/null 2>&1 ; then echo "-loraolap9" ; fi` -lslax9 -lpls9 -lplp9 -lserver9 -lclient9 -lvsn9 -lwtcserver9 -lcommon9 -lgeneric9 -lknlopt -lslax9 -lpls9 -lplp9 -ljox9 -lserver9 -locijdbcst9 -lwwg9 `cat /oracle/DC1/920_64/lib/ldflags` -lnsslb9 -lncrypt9 -lnsgr9 -lnzjs9 -ln9 -lnl9 -lnro9 `cat /oracle/DC1/920_64/lib/ldflags` -lnsslb9 -lncrypt9 -lnsgr9 -lnzjs9 -ln9 -lnl9 -lmm -lnls9 -lcore9 -lnls9 -lcore9 -lnls9 -lxml9 -lcore9 -lunls9 -lnls9 `cat /oracle/DC1/920_64/lib/ldflags` -lnsslb9 -lncrypt9 -lnsgr9 -lnzjs9 -ln9 -lnl9 -lnro9 `cat /oracle/DC1/920_64/lib/ldflags` -lnsslb9 -lncrypt9 -lnsgr9 -lnzjs9 -ln9 -lnl9 -ltrace9 -lnls9 -lcore9 -lnls9 -lcore9 -lnls9 -lxml9 -lcore9 -lunls9 -lnls9 `if /usr/ccs/bin/ar tv /oracle/DC1/920_64/rdbms/lib/libknlopt.a | grep "kxmnsd.o" > /dev/null 2>&1 ; then echo " " ; else echo "-lordsdo9"; fi` -lctxc9 -lctx9 -lzx9 -lgx9 -lctx9 -lzx9 -lgx9 -lordimt9 -lnls9 -lcore9 -lnls9 -lcore9 -lnls9 -lxml9 -lcore9 -lunls9 -lnls9 -lsnls9 -lunls9 -lxsd9 -lnls9 -lcore9 -lnls9 -lcore9 -lnls9 -lxml9 -lcore9 -lunls9 -lnls9 `cat /oracle/DC1/920_64/lib/sysliblist` -lm `cat /oracle/DC1/920_64/lib/sysliblist` -lm -lpthread -lpthread `if /usr/ccs/bin/ar t /oracle/DC1/920_64/lib/libskgxp9.a | grep '^'skcsi.o > /dev/null 2>&1 ; then echo "/opt/clic/lib/hpux64/libclic_csi.a";fi`

ld: (Warning) Ignore library $2$s with bad machine type 795832929

ld: Mismatched ABI for -lodm9, found /oracle/DC1/920_64/lib//libodm9.sl

Fatal error.

  • Error exit code 1

Best Regards

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Nov 27, 2007 at 02:12 PM

    Hi Monica,

    Are you sure all your Oracle binaries and patches applied are for IA64 architecture?

    Just look at the error message:

    ld: (Warning) Ignore library $2$s with bad machine type 795832929 ld: Mismatched ABI for -lodm9, found /oracle/DC1/920_64/lib//libodm9.sl Fatal error. *** Error exit code 1

    At Itanium, the "standard" library extension is ".so" and not ".sl" (this is PA-RISC)...

    Best Regards,

    JC Llanes.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 27, 2007 at 03:17 PM

    yes, i´m trying install de Patch Set HPUX IA64

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Monica

      ODM is the oracle disk manager, which is part of the veritas storage foundation. Have you ever heard of this?

      I cannot exactly tell you what is wrong on your system, but there are two files in $ORACLE_HOME/lib. As far as i remember, when you use ODM then you have to link libodm.so to the library provided by veritas. Maybe you are not using ODM at all, i can show you how things should be then:

      lcoalhost:/# uname -a
      HP-UX localhost B.11.23 U ia64 xxxxxxxxxx unlimited-user license
      localhost:/# model
      ia64 hp server rx4640
      localhost:/# ll /oracle/SID/920_64/lib/libodm*
      lrwxrwxr-x   1 orasid     dba             11 Dec 20  2005 /oracle/SID/920_64/lib/libodm9.so -> libodmd9.so
      -rwxr-xr-x   1 orasid     dba          10192 Nov 25  2004 /oracle/SID/920_64/lib/libodmd9.so

      So please check whether you have the link libodm9.so pointing to libodmd9.so.

      EDIT: please check the file permissions, it is highly possible that there is the 'x' execute permission missing.

      Best regards, Michael

      Message was edited by:

      mho

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.