Skip to Content
0

SAP Cloud Platform : Basic Authentication showing when accessing service in WEB IDE app. Why?

6 days ago

65

avatar image

I'm using a the same destination on a number of apps, which are connecting fine.

Created a new app (using the same SAP WEB IDE template).

The Service is retrieved fine when selecting New/OData service from the project menu, proving my Destination credentials are fine.

Now, when I run the app. I'm getting a basic authentication window. Cancelling this means I can't connect to the metadata of the service and therefore can't retrieve any data.

https://webidetesting0837185-s0015641139trial.dispatcher.hanatrial.ondemand.com/SAPUI5-ABAP-SFI/sap/opu/odata/sap/ZSV_SURVEY_SRV/$metadata?sap-language=EN 401 (Unauthorized)

My username and password is not being accepted even though it's correct.

Any ideas?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
Adam Harkus yesterday
0

And the solution was.....

It fixed itself!

:(

Share
10 |10000 characters needed characters left characters exceeded
Jamie Cawley
5 days ago
1

I would suggest tracing the call in SMICM to see what is happening.

Regards,

Jamie

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Could you please give a bit more detail.

How do I track it?

0
In SMICM you will find the tracing options under to goto menu.

https://wiki.scn.sap.com/wiki/display/XI/ICM+Trace

Regards,Jamie
0

Thanks Jamie

0
Jamie Cawley
6 days ago
0

Have you tried running the service directly? Maybe your user does not have the appropriate rights.

Regards,

Jamie

Share
10 |10000 characters needed characters left characters exceeded
Adam Harkus 5 days ago
0

Hi

Yes, I've run the Service in SAP GUI - Gateway Client with the exact same credentials. Works fine.

The Destination works fine in existing apps, it's seems to be related to the Data Connection facility in Web IDE (for this particular connection).

E.g. For destination SAPUI5-ABAP-SFI i'm trying to access ZRUI_COMMON_SRV.

- Works fine for another destination....

- Works fine for a previously deployed app using the same same destination and service.


capture.png (29.9 kB)
Share
10 |10000 characters needed characters left characters exceeded