Skip to Content

Database Table related

Hi all,

I have a table ZPPSFCTSTPDET in which i have i added some fields and i want to insert data in that. when i go to T-code sm30 -> Disply it is showing names of some of the fields only and remaing are shwon as ' + ' sign . I dont know why it is not showing name of somefields. please tell me why it is not showing in that.

In table display in se11 it showing properly and in delivery maintance tab i hv given maintence allowd. but still i dont know the prob.

<b>useful answer rewarded.</b>

regards,

sunil kumar.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    Posted on Nov 24, 2007 at 10:31 AM

    You have to assign DATA ELEMENTS to the Fields for which + sign is appearing in SM30.

    Fill the Field Label also for these data elements and regenerate the table maintenance

    This issue happens when you assign direct types to the fields while defining the database. Instead of Direct type use DATA ELEMENTS for these fields

    Regards,

    Abhishek

    Message was edited by:

    Abhishek Jolly

    Add a comment
    10|10000 characters needed characters exceeded

    • Abhishek Jolly Sunil Kumar kairamkonda

      Have you regenerated the table maintenance?

      Try the regeneration. The new changes will be updated only with Regeneration of the maintenance.

      Utilities -> Table Mainteance Generator.

      save the settings in a notepad. Delete the maintenance. Re-Create the maintenance with the same settings.

      Then again /nSM30 and see the table.

      <b>Reward Points if useful</b>

      Regards,

      Abhishek

      Message was edited by:

      Abhishek Jolly

  • author's profile photo Former Member
    Former Member
    Posted on Nov 24, 2007 at 10:31 AM

    Maintain field label for the data element which you have used to define type of the added field.

    Regards,

    Amit

    *Always reward points for helpful answers

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.