Skip to Content
0

GRC 10 entries automatically deleted from EAM User, Owner and Controller Tables for 1 connector

Oct 10, 2017 at 02:36 PM

64

avatar image

We have a major issue and would appreciate assistance. We are using GRC 10. Sometime after 22:30 system time Monday 10.09.2017, all entries from 1 connector (YPE) were deleted from the GRACFFUSER, GRACFFCTRL and GRACFFOWNER Tables. Entries from OTHER connectors were NOT deleted. Unfortunately we did not have logging turned on for those 3 tables so we can't check the change history.

Yesterday, EAM worked successfully to YPE from our GRC production instance (YPR), both the Repository and PFCG synch jobs ran successfully toward YPE and the GRC connector to production instance YPE was also working successfully.

No notes were applied yesterday and we had no recycle.

Does anyone have any idea what could have occurred?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Alessandro Banzer
Oct 31, 2017 at 06:43 PM
0

Novella,

this is an old thread. Is it still present? Were you able to fix the issue? Did you check if someone performed mass changes or if a repository sync job deleted the data? Might be that the sync ran but the systems were not up.

Regards, Alessandro

Share
10 |10000 characters needed characters left characters exceeded
Novella Jane Landreth Nov 01, 2017 at 02:45 PM
0

Hi, Allesandro. No, I didn't get any helpful information. Unfortunately we didn't have logging turned on so we couldn't check the table update history. I have a few questions related to your response:

1. Under what circumstances could the repository synch job delete EAM table data?

2. If the synch ran successfully (which it did) but the connected system was down, would the fact that no data was retrieved cause the previous entries for that connector?

3. If a connected system is down, wouldn't the repository synch job have an error condition or is it possible that it could still show successful execution even though the connected system was down and no data was fetched?

I really appreciate your checking in to see if I got an answer.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Novella,

I remember that there were some issues with version 10.0 (on certain SP's) that when a system was not available, the sync job would delete the data. I guess it was somewhat like "SELECT * FROM BACKEND", "WIPE WHERE SYSTEM=BACKEND", and then "INSERT INTO". Since the INSERT was an empty table and the WIPE worked, everything was deleted. But I must be honest, I can't find a note.

What's your current SP level?

Cheers, Alessandro

0