Skip to Content
avatar image
Former Member

How to Disable Tools-->Form settings option..

Hi Experts,

I have created two users User1 and User 2, i want the form settings option to be disabled for the 2nd user. How to Disable it? Any Inbuilt settings in SAP B1.

waiting for the earliest reply.

Regards,

Magesh.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Nov 23, 2007 at 07:26 AM

    Hi,

    I would say Administration / System Initialization / Authorizations / General Authorizations, then General and Document settings.

    But where I'm actually, I can't test to verify.

    Regards,

    Eric

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 23, 2007 at 07:50 AM

    Hi there!

    1. Go to the View and check the box Debug Information.

    2. Open the wanted Form Settings window and check up unique ID of the form (e.g. Form Settings - Sales Order form have ID=998).

    3. Open Administration -> System Initialization -> Authorizations -> Additional Authorization Creator.

    4. Create new user authorization. See the F1 help if needed.

    5. Don't forget to press Edit button in this form and paste to Additional Authorization Forms ID your unique ID checked up at item 2 of my message (998).

    6. Open Administration -> System Initialization -> Authorizations -> General Authorization.

    7. Select necessary user and find previously created authorization under User Authorizations item (the last one).

    8. Change the authorization from No Authorization to Read-Only or Full Authorization value.

    HIH,

    Anton.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Magesh,

      You can set from:

      1. Administration > System Initialization > Authorizations > General Authorizations

      2. Choose the user

      3. Choose Group General > Document Settings, give No Authorization.

      Hope it helps.

      Regards,

      Ida

  • avatar image
    Former Member
    Nov 23, 2007 at 09:19 AM

    Hi Magesh,

    You can set from:

    1. Administration > System Initialization > Authorizations > General Authorizations

    2. Choose the user

    3. Choose Group General > Document Settings, give No Authorization.

    Hope it helps.

    Regards,

    Ida

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 06, 2007 at 09:38 AM

    Hi magesh,

    You can do it by creating Additional authorization,follow the below path

    Administration>System Initialization> Authorizations-->Additional authorization

    creator.

    Enter authorization id,name,option,Click update.

    Click Add sub-level.

    Enter authorization id,name,option,Click edit button next to form setting,

    Enter form id for Form settings,For ex,63771,Click update,Click update.

    Now click open general authorization>Select required user>User authorization-->

    Set required authorization(Full/Read/No).Click Update.

    Hope above solution will solve the problem.

    With regards,

    Jeyakanthan

    Add comment
    10|10000 characters needed characters exceeded