Skip to Content

BW HIER doesn't import to BPC QUESTION

Hello experts,

I have read many articles about BW hier and how to import them to BPC.

I am in BPC 10.1 Classic and I am trying to import a BW HIER. This HIER is the Chart of Accounts that comes from ECC. I look in Transaction RSH1 and I see the next HIER:

In BPC I generate the DATA MANAGER using the PROCESS CHAIN /CPMB/IMPORT_IOBJ_MASTER, In the selection I select "Filter by attributes or Hierarchy":

In the Hierarchy tab I select the Hierarchy:

and run the DM.

I Just got the Accounts imported and the TOP level of the HIER BP. The tranformation file i used is jsut the acctype = *Str(EXP) since this field is mandatory, also tried with a suggested Tranformation File:

*MAPPINGNODENAME=NODENAMEHIER_NAME=HIER_NAMEPARENT=PARENTORDER=ORDER*CONVERSIONHIER_NAME=CONV_HIER.xls!

But didn´t work

Any Ideas what am I doing wrong.

Thanks for the post.

Best Regards.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Oct 10, 2017 at 05:30 PM

    Sorry, but /CPMB/IMPORT_IOBJ_MASTER is used to import master data only.

    And mapping has to be done to import master data, not hierarchy.

    To import hierarchy you have to use: /CPMB/IMPORT_IOBJ_HIER

    P.S. Please read:

    https://blogs.sap.com/2013/01/21/bpc-10-nw-master-data-attributestext-and-hierarchy-loading-process-part1/

    https://blogs.sap.com/2013/01/21/bpc-10-nw-master-data-attributestext-and-hierarchy-loading-process-part2/

    Add comment
    10|10000 characters needed characters exceeded

    • When you import master data based on:

      Plan de cuentas=0010 Or Hierarchy= BPB9

      1. All base members of 0GL_ACCOUNT with Plan de cuentas=0010 will be imported

      2. All hierarchy nodes of BPB9 will be imported looking like BPB9xxxxx. Can be a good idea to remove BPB9 string in the conversion file for ID: external: * internal: js:%external%.toString().split('BPB9').join('')

      Please check that master import is correct.

      Then you import hierarchy just selecting hierarchy name BPB9

      You have to use the same conversion file for NODENAME and PARENT to remove BPB9

  • Oct 12, 2017 at 04:15 PM

    Thanks for the correction Vadim,

    I added the conversion file ti the tranformation:

    I got an error for the js, but also I see in the log that just 1 HIER was taken:

    :( any Ideas,

    What I was thinking was to manually upload the HIER using the dimension members in Transaction RSH1 and then run the HIER DM.

    Add comment
    10|10000 characters needed characters exceeded

    • Bad idea (upload manually the HIER"), the process has to work without issues!

      It's absolutely basic thing, working everywhere...

      Better to perform ABAP debugging to find the reason.:

      Read https://archive.sap.com/documents/docs/DOC-4230

      Create single badi with the following simple code with endless loop:

        method IF_UJD_ROUTINE~RUNROUTINE.
          DATA i_d TYPE C. " for bg debug.
          CLEAR i_d.
          WHILE i_d IS INITIAL.
          ENDWHILE.
      
          er_data = ir_data.
        endmethod.

      Add to transformation file line:

      STARTBADI=FILTERNAMEOFCREATEDBADI

      Launch package

      Open SM50 - find the line with endless loop -> select this line

      Menu->Administration->Program->Debugging

      Debugger will open

      Set the value of i_d to X

      In Locals you will see a table

      er_data

      Containing records before transformation and conversion. Can be exported to Excel and analyzed.

      Select Continue to execute badi - debugger will close.

  • Oct 11, 2017 at 06:01 PM

    Hello Vadim,

    Thank you for all the tips, I did as you say, I erased from HIER_NAME BPB9,

    Tranformation File:

    th conversion for CONV_HIER:

    Conversion node and parent:

    I tried with more statements sucha as js:%external%.toString().split('BPB9').join('') and js:%external%.toString().split("BPB9").join(""):

    1. Data Manager still gets just 1 HIER.

    2. Got an error witht the java code.

    I attach the LOG:

    I still looking for what is happening.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 11, 2017 at 09:59 PM

    I really apologize for my missunderstanding,

    The screens for the Accounts import are:

    Filter by atributes OR Hier.

    Import NODE text

    This is tha info for the Master Data, what I get when in finish is success but the TEXT for the HIER just brings the top of the HIER BPB9

    Regards

    Add comment
    10|10000 characters needed characters exceeded