Skip to Content
0

SXI_CACHE error 'http_body_size = 0' then 'HTTP status code 400 bad request'

Oct 09, 2017 at 03:39 PM

78

avatar image

Dear Expert,

I once try to refresh delta cache from SXI_CACHE but get an error. Resulting in an error 'http_body_size = 0' messages could be processed, Java stack is so slow and I cannot access ESR, IB, RWB, Monitoring, NWA. Because every time it tries to authenticate me, I get the error "Authentication failed"

Then I do a sap restart, the ABAP & Java stack is up, but still no messages could be processed, etc.

- Checking the INTEGRATION_DIRECTORY_HMI connection results in OK but it took like 4 minutes to finish.

- Pressing F7 in SXI_CACHE shows that everything is ok, except the cache status is inconsistent

- Checking by Basis team, that there are some processes run by SAPCACHEUSER (if I'm not mistaken) that haven't finished and is still running.

Then I try to do a full cache refresh from SXI_CACHE but I get the error cache refresh error 'HTTP status code 400 Bad Request' while executing HTTP request (calling method 'get_status')'

Then I try to do the solution in this thread Error 'HTTP status code 400 Bad Request' while executing HTTP request (calling method 'get_status') by changing the path of INTEGRATION_DIRECTORY_HMI to '/dir/hmi_cache_refresh_service/ext'. Then running a full cache refresh in SXI_CACHE is like loading forever.


Final status is that the ABAP & Java stacks are up, but the Java stack cannot process anything and there are still some processes run by SAPCACHEUSER.

How to troubleshoot this issue?


10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Suwandi Cahyadi Oct 10, 2017 at 06:17 AM
0

Dear All,

Issue solved by killing all the processes by PICACHEUSER, the PICACHEUSER processes are consuming all the dialog work process and it slows the server.

Now, cache is updated and messages could be processed normally.

Share
10 |10000 characters needed characters left characters exceeded
Rudra Singh Oct 10, 2017 at 06:06 AM
0

Hi,

Please check if SLD components are installed properly. There should be 6 components should be installed. Please find the details below.

https://blogs.sap.com/2013/06/13/triggering-sld-registration-of-pi-components/

Along with that please check exchange Profile parameters are configured properly or not

This issue mostly occur due to inconsistent SLD and exchange Profile Parameters.

Warm Regards,

Rudra

Share
10 |10000 characters needed characters left characters exceeded