Skip to Content
author's profile photo Former Member
Former Member

Problem with creating new view and binding it wht existing ViewSet/viewArea

Hi All,

I created a new view.

Now I am trying to dynamically change the veiw in ViewArea : product of ViewSet : BupaMainViewSet .

I added my new view in the views for viewarea : "product".

Now I wanted to get this new view based on some button clicks on view BupaSearchB2B.

If search Account button is clicked my new View has to appeared. Othewise the standard view in the Product view area shud appear.

I dont know how to do.

Your response will be highly appreciated with your reward points.

kindly assist me on this.

Thanks,

SR.

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Posted on Nov 21, 2007 at 09:17 AM
  • author's profile photo Former Member
    Former Member
    Posted on Nov 21, 2007 at 10:05 AM

    Hi Sreesanth,

    which version of CRM you are working on ?.

    if it is 4.0.

    you have to modify the xml code in the custom DT_REP application, where you have to give path of your view( application/view ) in the relevant viewarea.

    you need to create a navigationlink in the custom DT_REP application. refer the application you can just copy and modify the xml code. give source view as BupaSearchB2B and target view as 'yourapplication/yourview'. note the name you given to the navigational link.

    since you want to call the view only when a button is clicked. create an event handler method. call the navigational link by passing the name of the navigational link you have created in DT_REP. ( code for doing the same will be available from some methods in any cotrollers of the standard application( CRM_IC ).

    Regards, Sudeep..

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks Sudeep.

      I have done the similar things which u mentioned. But that button click is not working.. Its not giving any errors or exceptions. it is behaving the same standard way. Is there is something missing....

      SR

  • author's profile photo Former Member
    Former Member
    Posted on Nov 22, 2007 at 05:05 AM

    Hi SR,

    r u using IC web client ?

    If so please let me know, i can help you out in this.

    Thanks & Regards,

    Vinay

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.