Skip to Content
author's profile photo Former Member
Former Member

Batch Input for Parked Invoice (FB60) - Lag in creation ???

Hi folks,

I'm using a batch input on FB60 so as to generate a parked invoice. Furthermore, I'm calling it in complex posting 'cause sometimes it implies posting on asset (posting keys 70 and 75).

The point is that the batch input works fine, but sometimes in the exact same situtation, with non rationnal explanation.

I'm using this :

sl_bdcoption-dismode = 'N'.

sl_bdcoption-racommit = 'X'.

sl_bdcoption-nobinpt = 'X'.

sl_bdcoption-updmode = 'L'. " or A or S, still the same

CALL TRANSACTION 'FB60' USING tl_bdcdata

MESSAGES INTO tl_messtab

OPTIONS FROM sl_bdcoption.

COMMIT WORK AND WAIT.

so that I can catch the number of my created invoice from the message table. Indeed I need this to update BKPF which has some custom fields (on the Basis Data tab). All the transactional controls on my custom fields are deactivated through an Export to Memory and I know how the screen displays with the option sl_bdcoption-nobinpt = 'X', both set before the call.

First I thought my bug was coming from the Update Mode in structure sl_bdcoption, but I've tried to set it to A, S or even L. I've tried many options from that structure, but the bug remains random...

How can I be sure that the call is ended and that my new invoice is created ?

Any oher way I can do this ? Any BAPI I haven't found ?

Thx in advance for your help,

NH

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Nov 20, 2007 at 06:47 PM

    You might try to lock the record in bkpf.

    Rob

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Rob,

      Indeed it works fine manually. Well, I've set the Batch Input mode to E, I hope I will see why someone has troubble again when the issue occcur.

      Thx for your time, I'm closing the point, since it's abnormal to have the message table not entirely filled in.

      NH

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.