Skip to Content
avatar image
Former Member

SAP HANA EXPRESS EDITION : Unable to connect to hana server without internet connection

Hi,

I am able to connect to HANA server(VM guest) from HANA studio (Host windows) when I have internet connection. As soon as I disconnect the internet connection, connection is lost.

How do I resolve this ?

I was not getting the IPV4 address in /sbin/ifconfig. After connecting to internet I am able to get the IP address. The same IP address I have maintained in hosts file /windows/system32/drivers/etc.

Need your inputs here. Please.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Oct 09, 2017 at 12:42 PM

    Hi again Mohammed,

    You ask the same question, you get the same answer. ;-)

    Make sure to configure the VM (Networking) for the host-only setting (not Bridged, not NAT).

    Step-by-step Stop VM, if started. VM > Settings > Network Adapter > Host-only Start the VM

    Query IP with ifconfig Connect with client on the host (studio, terminal, PuTTY, browser, etc.) using this IP.

    Optionally add the IP of the VM (guest) to the hosts file of your computer (host).

    Bridged is also possible but requires more work. NAT requires a network.

    Issue solved?

    Regards,

    Denys / SAP HANA Academy

    Subscribe to our YouTube Channel
    Join us on LinkedIn
    Follow us on Twitter
    Github code samples
    Facebook
    Google+

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Denys,

      Great video, how difficult will it be if I'll have my VM setup to be in "NAT" instead of "Host-Only" mode.

      Currently, I'm having a VM HXE installation with multiple vm netcards of "NAT" and "Host-Only" netcard settings just to explore on the setting up the connection between my Host and HXE systems with the aim of having Internet access on both systems.

      Please advise on the effort needed for NAT and if my setup is possible for my mini HXE lab.

  • Dec 12, 2018 at 09:50 AM

    Hi Noel,

    In some environments, running the ifconfig command on the guest does not return a IP v4 address. A workaround for this issue is to configure the VM Networking in Host-only mode.

    If you do not have this issue, there is no reason to switch to host-only. You can stay in NAT. It is the default; i.e. if it ain't broke, don't fix it.

    Both NAT and Bridged provide internet access to both guest and VM, just the implementation differs, cf.

    https://docs.vmware.com/en/VMware-Workstation-Player-for-Linux/15.0/com.vmware.player.linux.using.doc/GUID-C82DCB68-2EFA-460A-A765-37225883337D.html

    Would this answer your question?

    Add comment
    10|10000 characters needed characters exceeded