Skip to Content
0

Exchange data sources - Lumira 2.0 on BI platform - No service implementation

Oct 06, 2017 at 06:04 PM

824

avatar image
Former Member

Hi guys,

I`ve created a very simple designer application with one crosstab pulling data from one BW query.

Using Lumira 2.02 Patch 3 and SAP BusinessObjects Business Intelligence 4.2 Support Pack 4 Patch 3.

If I run the report locally, it works perfectly well. As soon as I execute on the BI platform, it shows me the following error:

I`ve seen this error before: https://answers.sap.com/questions/300685/lumira-20-report-does-not-show-on-bi-platform-no-s.html

The solution proposed in the other disucssion does not help this time, since we are above Patch 2 Hotfix 1.

While publishing to the BI platform, the designer shows this message to me:

Not that I didn`t try to exchange the data source, but was not really sucessful.

There is an valid OLAP connection from the BI platform to the BW system from where the data should be pulled.

Any ideas?

Thank you + Best,

Marcus

10 |10000 characters needed characters left characters exceeded

Hi Marcus,

A couple of points:

1) Your terminology relating to the versioning is a little confusing. You refer to "Lumira 2.02 Patch 3" and "patch 2 Hotfix 1". The latest Lumira version is Lumira 2.0 SP02 Patch 1. Is this what you meant?

2) Can you post some screenshots showing the steps you took to exchange your BW connection when uploading to the BI Platform?

Thanks,

Mustafa.

0
Former Member
Mustafa Bensan

Hi Mustafa,

Thank you!

1) Right. Sorry.

The latest Lumira version is Lumira 2.0 SP02 Patch 1. Is this what you meant? --> Yes

2) This is how I proceeded:

1. Create a local application by selecting a connection to a SAP BW system and choose a query

2. Upload this simple application to the BI platform

3. Open the application from the BI platform in Lumira Designer

4. Go to data sources and add a new data source (DS_2). This time I choose the same query over the general OLAP connection:

5. Go to the properties of the reporting item, in my case crosstab, and assign DS_2, which is the same query, but it comes over the general OLAP connection:

6. Synchronize with BI platform. This is what I have missed in the first attempt. That was why the report was not shown on the BI platform.

The little asterik shows that one has to synchronize:

Result: My report is now also shown on the BI platform.

Is this the right course of action? Do you know an easier way?

I mean in design studio there used to be an option where connections could be maintened at data source level:

Thank you + Best,

Marcus

1.png (54.5 kB)
2.png (20.9 kB)
3.png (83.1 kB)
4.png (19.2 kB)
5.png (30.9 kB)
5.png (33.0 kB)
6.png (16.1 kB)
0
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Mustafa Bensan Oct 10, 2017 at 06:10 AM
0

Hi Marcus,

There is no need to create the second data source (DS_2) after uploading to the BI Platform. The original data source (DS_1) can be directly maintained to reassign the local connection to an OLAP connection. Below is an example I created with one data source and Crosstab:

1. The local assignment looks like this:

2. After uploading to the BI Platform but before reassigning the data source, an error message is displayed as expected when executing the application:

3. Data source DS_1 is then reassigned on the BI Platform as shown below:

4. After synchronising with the BI Platform, the updated application with reassigned data source executes without errors:

Regards,

Mustafa.


Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Mustafa,

great. That was I was looking for.

Thank you!

Always a pleasure to read your posts and blog entries.

Meanwhile I have also found this post: https://answers.sap.com/questions/314836/how-to-refresh-lumira-designer-universe-connection.html

Tammy`s answer points to an interessting note from SAP learning hub:

I will carry this note as a best practice to my customers and projects and try to not play around with the connection settings ;)

Thank`s again + Best,

Marcus

1.png (115.1 kB)
1

You're welcome, Marcus. Thanks for your feedback :)

1
avatar image
Former Member Oct 09, 2017 at 12:42 PM
0

Hi Marcus.

If I haven't remenber wrong,lumira 2.0 couldn't support OLAP connection,which should HTTP connenction.

Best regards.

Jing

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Jing,

The HTTP connection is only relevant for HANA data sources. BW data sources still use the standard OLAP connection.

Regards,

Mustafa.

0
avatar image
Former Member Jan 08 at 05:11 PM
0

Hi Guys,

I am trying to do this same exact thing, uploaded a local lumira document to BI platform for Lumira Designer, successfully.

Now, while assigning Datasource connection to the 'SAP BW' OLAP connection that is maintained, when I click on 'Browse Connections', it keeps loading for

Sometimes, it finishes processing, whatever it is doing, and doesn't give any connection list.

Also, did a search for 'SAP BW', that did not work.

I have done this before many times and it has worked most of the times, every now and then it gives me trouble exchanging datasources.

Here is an example below, where it worked fine.

Any ideas on why it takes so long to look for the OLAP connection 'SAP BW' in this case?

Why does it now load any connections on 'Browse Connections' ?

regards

Varun


0io7y.png (23.6 kB)
7tkzj.png (23.6 kB)
ceq1u.png (47.5 kB)
cz097.png (30.9 kB)
26cd3.png (29.7 kB)
Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Varun,

which version of the designer are you exactly using?

I`ve tried this with 2.0 SP03 a few days ago and it worked successfully.

Thank you,

Marcus

0
Former Member

Hi Marcus,

We have Lumira designer 2.0 SP2 patch 3.

The funny thing is it works sometimes, other times it doesn't. Have to keep reloading/restarting designer.

Like for example, today it worked for me.

Doesn't make sense, why this connection would appear and disappear, also when we click on Browse, it takes a long time to lookup connections.

regards

Varun

yfooy.png (46.5 kB)
0