Skip to Content
avatar image
Former Member

​The Promotion Management Create button does not work always

Hello,

I need your advice on the issue below. Clicking on Create Button to create a new job does nothing for most cases.

Environment Details:

Development, QA/UAT - Standalone, Production - Cluster of 2 Servers - All on BI 4.2 SP04

Tomcat 8 (default)

CMS Database - MS SQL Server 2014

OS - Windows Server 2012

Here are my observations.

----Using Promotion Management on Development

Source Target Create (Yes/No)

DEV UAT No - Clicking on Create Button does not move forward

UAT DEV No

DEV PROD1 No

DEV PROD2 No

UAT PROD2 YES - This one Works

DEV LCMBIAR No

---- Using Promotion Management on UAT

Source Target Create (Yes/No)

UAT DEV No

DEV UAT No

UAT PROD1 No

UAT PROD2 No

UAT LCMBIAR No

---- Using Promotion Management on Production

Source Target Create (Yes/No)

DEV PROD1 No

UAT PROD1 YES - this one works

PROD1 UAT No

PROD2 UAT No

PROD1 LCMBIAR No

PROD2 LCMBIAR No

I had initially suspected to be a firewall issue but if that is the case, output destination to LCMBIAR should at least work if not Live to Live but clicking on Create in none of the environments for destination to LCMBIAR works.

Firewall Ports from 6400 to 6420 are bidirectionally opened between the Servers. Request Port and IP Binding have also been manually assigned for the following Services in all environments. But still the same issue.

CMS (6400 default), Request Port 6401

IFRS Request Port 6402

OFRS Request Port 6403

Promotion Management Services - Adaptive Job Server Request Port 6407

Promotion Management Services - Adaptive Job Processing Request Port Core 6408

WACS Request Port 6415

Tomcat Ports 80, 443

I do not see what all ports are needs for Promotion Management in Admin Guide. Enabled CMC Application Logs and I see quite a lot of the following, not sure what that means though.

"Failed to get session id from handle and handle is not set to bypass nor server-server discovery"

Has anyone come across the issue and can advise on what may be the cause of the issue?

Thank you.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Oct 09, 2017 at 04:57 PM

    I'm not entirely sure where in the PM workflow this happens exactly, but you should run end to end trace of the workflow. (KBA 1861180)
    And see what's failing either in CMC webapp log or in CMS logs.

    As far as firewalls are concerned, you do not need any extra ports connecting to source system, except CMS/FRS port/requestports. To get to destination you'll need additional ones depending on content promoted (CR, Dashboard, APS servers ports might be needed).

    Promotion servers are assumed to be local to tomcat on which CMC is being run.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 09, 2017 at 08:52 PM

    Thank you Denis for your inputs. I was able to work past the issue by using "Localhost" instead of Server Name / IP in the Source System field and create a BIAR file to be imported to other environments. Appears to be a DNS issue.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 09, 2017 at 10:09 PM

    Vijay,

    Have you tried running Promotion Manager on same system to LCMBIAR? Logon on to UAT and create NEW PM Job from UAT to LCMBIAR. Then repeat the process on each system from itself, DO NOT connect to another system This will confirm if it is network related issues. If you only have problems when creating new PM job to non-local system then the problem is confirmed to be network related.

    Regards,

    Ajay

    Add comment
    10|10000 characters needed characters exceeded