Skip to Content
author's profile photo Former Member
Former Member

Problems with exclusion mask

Hello guys,

I have one problem with two sender file adapters.

Both adapters have same file name INB_HU and I have 4 files:

XAINB_HU.txt

XBINB_HU.txt

XCINB_HU.txt

XDINB_HU.txt

I want to process files XA* and XB* with one adapter and files XC* and XD* with the other adapter.

Actually both adapters have the same file name but when I leave the 4 files, all are being processed by the same adapter.

We have tested filling Exclusion Mask of one adapter with XA,XB and the other with XC,XD but is not running, all files are processed in one adapter.

Another try was to put in Directory the same for all the files and in File Name Mask put XA* and XB* and in the other XC* and XD^* leaving Exclusion Mask empty, and also the files are processed by only one adapter.

Anybody knows how to perform this action?

Many thanks in advance,

Xavier.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

7 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Nov 14, 2007 at 09:28 AM

    HI,

    Please go through the weblog this will help you.

    /people/mickael.huchet/blog/2006/09/18/xipi-how-to-exclude-files-in-a-sender-file-adapter

    2 files in 1 communication channel

    Thanks and Regards,

    Chirag Gohil

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 14, 2007 at 09:43 AM

    Hello Chirag,

    the problem is that I have two adapters with the same file name, not one.

    I know how to include or exclude files with one adapter, but the problem is that I have two adapters with the same file name. One to process 2 files and the other adapter for the other two files.

    The problem is in the adapter that process files XA* and XB* how to exclude files XC* and XD* becasue we tried but we don't know how to do it.

    Regards,

    Xavier.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 14, 2007 at 10:12 AM

    Hello,

    where should I put the filenames? In the File Name I can not fill with two filenames.

    We put the names in File Name Mask with the directory and is not running.

    Anybody has an idea?

    Regards,

    Xavier.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 14, 2007 at 10:30 AM

    HI,

    Go for <b>Advance Selaction for source file</b>

    Directory : : File Name mask : : Exclusion Mask

    <b>XI/xxx/ : : XAINB_HU.txt : :

    Xi/xxx/ : : XBINB_HU.txt</b> : :

    same in seccond adapter.

    hope this will help.

    regards

    HONEY

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 14, 2007 at 12:21 PM

    Hi Honey,

    now is processing one of the files of the adapters, now I have:

    Adapter1:

    Directory : : File Name mask : : Exclusion Mask

    <b>XI/xxx/ : : XAINB_HU*.txt : :

    Xi/xxx/ : : XBINB_HU*.txt</b> : :

    Adapter2:

    Directory : : File Name mask : : Exclusion Mask

    <b>XI/xxx/ : : XCINC_HU*.txt : :

    Xi/xxx/ : : XDIND_HU*.txt</b> : :

    Now is processing well file XAINB_HU.txt and XAINC_HU.txt, but file B is entering in adapter2 and file D is entering in adapter1.

    Do you know hot to avoid this error?

    Regards,

    Xavier.

    Message was edited by:

    Xavier Carbonell

    Message was edited by:

    Xavier Carbonell

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 15, 2007 at 09:39 AM

    Hello Honey,

    the filename comes with timestamp, so I have to use * because we don't know the complete name of the file.

    Anybody knows how to solve it?

    Regards,

    Xavier.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      hi Xavier ,

      if you talking about timestamp file which is coming from XI , so you can remove it , there is option<b> Add Time Stamp</b> , dont go for that, selact <b>CREATE</b>.

      hope this will solve your isssue.

      regards

      HONEY

  • author's profile photo Former Member
    Former Member
    Posted on Nov 20, 2007 at 09:25 AM

    Hello,

    I have an exclusion mask problem with a couple of interfaces. They are both configured to process 2 kind of files each, and they have to take these files from the same path.

    Interface 1 should process files that begins with CTXX_XXXX_.txt and DEXX_XXXX_.txt

    Interface 2 should process files that begins with MY_XXXX_ .txt and ID_XXXX_.txt

    For this purpose, I have configure the advance selection parameters for both communication channels in the following way:

    For interface 1

    [IMG]http://img517.imageshack.us/img517/442/71441041jw1.jpg[/IMG]

    The filenames circled in blue are the ones I want the interface to process. The names circled in red are the ones I do not want this interface to process.

    For interface 2

    [IMG]http://img209.imageshack.us/img209/306/57700933vi6.jpg[/IMG]

    Here’s is the same configuration as above, the filenames circled in blue are the ones I want the interface to process, while the ones circled in red are the ones I do not want to process.

    The problem I’m having is that the interfaces are processing files in a rather random way, in other words, the exclusion mask configuration is not working at all. The files are processed either by one interface or the other one, in a way that does not follows any specific trend. I s there anything else I need to configure in XI, besides the Exclusion Mask, in order for this to work? Is the configuration I’m using the correct one? I know that what I’m doing is rather redundant, but I had tried many different combinations and still don’t work.

    Would you please help me with this?

    Best regards,

    Xavi

    Message was edited by:

    Xavier Carbonell

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      hi,

      I m nt sure abt this but can you try this,

      dont give any directory and file name initailly in<b> Source Directory and FileName</b>, only give the name and directory in exclusion mask option, <b>your directory and file name mask.</b>

      hope this will help

      regards

      HONEY

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.