Skip to Content

Increasing the Message Log time in SAP PI

Hi All,

I need to check the message logs for the messages processed 4 hrs back. But unfortunately message log is blank,the message log is only available for the current 1 hr. Where and how to update the message log settings to show/available logs atleast for 1day.

Thanks,

Vijay.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

8 Answers

  • Oct 13, 2016 at 05:39 PM

    Hello Vijay,

    Please check SAP Notes 1314974 (for asynchronous messages) and 1982452 (for synchronous messages with at least one logged version) - they both describe the default behaviour - which is deletion of message log entries stored in-memory for successfully processed messages - and the way how this can be changed and message logs persistence to database enabled using property 'messaging.auditLog.memoryCache' of Java service 'com.sap.aii.af.ms.svc'. Please check if your system uses default configuration for mentioned parameter and, if so, follow recommendations provided in referred Notes.

    Regards,

    Vadim

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 13, 2016 at 06:45 PM

    I was hoping you should see my question and reply to it. As you are "the Expert" in stagging and logging...Thank you very much! I will check the notes and get back, for any more questions.

    Regards,

    Vijay.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 14, 2016 at 02:47 PM

    Hi,

    The settings looks good in NWA as per the SAP notes. But I am not sure why still the message log is not displayed...Please find the below screen shots settings in my system, which is showing to display the log for 1 week:

    Thanks,

    Vijay

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 14, 2016 at 03:07 PM

    Hi Vijay,

    According to the SAP Note.

    The persistence of audit logs for successfully processed asynchronous messages may be required for business reasons or performance analysis therefore to revert to the behaviour of previous XI/PI versions (i.e., all asynchronous message audit logs are persisted to the database) change the value of the Messaging System service -
    com.sap.aii.af.ms.svc
    property -
    messaging.auditLog.memoryCache

    from the default
    'true'
    to
    'false'.

    (then Modify -> Save -> Restart Messaging Service ** )

    You need to change below parameter to false in your system.

    Regards,

    Praveen.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 14, 2016 at 03:20 PM

    Thank you Praveen. Let me ask My basis team to update the same. Any cons with this update?

    Regards,

    Vijay

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 14, 2016 at 03:34 PM

    Performance will be adversely affected by changing this value. why you want to keep the logs for successful messages? for system error messages logs will available until you cancel the message.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 14, 2016 at 06:17 PM

    Because of unknown alert raised by PI prod system, I tried to dig whether the alert caused by any message which is re-processed automatically. So I started opening each message to find out which is reprocessed automatically but unfortunately I did not find message logs for the messages. The alert issue drag me to message log issue.Coming to sap notes even I see that note mentioned about Performance will be adversely affected. But they have not mentioned how will it affect or if the saved messages will ever be pruned which makes me worry about database growth...

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 03 at 01:14 PM

    Can someone tell in which JAVA-DB-Table this Logging/AuditLog is written?

    I guess we should have an eye on that table, so that it do not "explode" :-)

    Add comment
    10|10000 characters needed characters exceeded