Skip to Content
2

SAP GUI for MacOS High Sierra. Can't open GUI Preferences.

Oct 04, 2017 at 07:56 AM

2.1k

avatar image
Former Member

Hi! After updating to MacOS High Sierra I can't open GUI Preferences. Also right button on GUI icon not working - I can't select gui opened windows (can't change systems by right click).

Is anyone have the same problem ?

tested on SAP GUI for Java (MacOS) 7.50 / 7.40 rev12 / 7.40rev9

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

6 Answers

Best Answer
avatar image
Former Member Oct 04, 2017 at 01:42 PM
1

Oh, I got it! The problem was in the russian language in MacOS interface. There is no other menu.

I changed MacOS preferences to english language and it works:

And SAP GUI preferences works too:

It works on 7.50 and 7.40 too.

Thanks !!!


Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Oct 04, 2017 at 01:36 PM
0

Hello Rolf-Martin, thanks for reply! Unfortunately I can't activate the trace - when I press SAPGUI in the top-left corner - nothing happened.

About java:

java -version

java version "1.8.0_144"

Java(TM) SE Runtime Environment (build 1.8.0_144-b01)Java HotSpot(TM) 64-Bit Server VM (build 25.144-b01, mixed mode)

Share
10 |10000 characters needed characters left characters exceeded
Rolf-Martin Woersinger
Oct 04, 2017 at 09:02 AM
0

Hello Igor,

MacOS High Sierra is not yet officially supported by SAP GUI for Java, but we are working on it for the 7.50 version.

Using SAP GUI for Java 7.50, could you please switch on tracing incl. trace file according to https://launchpad.support.sap.com/#/notes/0000683960

and try to open the preferences (and the other activities which do not work)?

Which pointing device are you using? Mouse, external/internal trackpad, which version? We also need to know the exact Java runtime version (should be in trace file).

With all this information, please create a support message on component BC-FES-JAV.

Best regards

Rolf-Martin

Share
10 |10000 characters needed characters left characters exceeded
Rolf-Martin Woersinger
Oct 10, 2017 at 08:23 PM
0

Hello Igor,

Your results helped us to understand the issue. We have submitted a bug report to Apple (the bug is part of the framework used for launching app bundles of Java apps, which comes from Apple). Other Java apps are affected as well.

Best regards

Rolf-Martin

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hello Rolf-Martin ! It's a pleasure to be involved in this process )

0
Thiago Lima Nov 13, 2017 at 05:43 PM
0

I have tried to install sap gui for java 7.50 with java 9 but it didn't work. Anyone does know how to solve it?

Show 3 Share
10 |10000 characters needed characters left characters exceeded

You should install JDK 8.

1

I have installed java 8 update 151 and the issue persists.

0
Former Member

I have to install again and it is working now. Thank you.

0
Rolf-Martin Woersinger
Nov 13, 2017 at 11:52 PM
0

Hello Igor,

In the beta of 10.13.2 recently posted, the issue seems to be solved.

Best regards

Rolf-Martin

Share
10 |10000 characters needed characters left characters exceeded