Skip to Content

How to install XSA for AWS?

Hi,

I am trying to install XS Advanced Runtime for AWS without success. It shows an error (Can't call method "Get version" on an undefined value at XsEventHandler.pm line 216):

HANA version 1.00.122.05.1481577062

XS RUNTIME 1 Patch Collection 35 (build 1.0.65) / PL 65 (install package EXTAPPSER00P_65-70001316.SAR)

SUSE Linux 11 SP4

Information about installation process has been taken from here:

https://blogs.sap.com/2016/02/15/sap-hana-xs-advanced-installation-guide-through-resident-hdblcm/

https://www.youtube.com/watch?v=Qzg7hhb5U2Q&list=PLkzo92owKnVxw3phZlW-rYI4Wj4TZ3k1m∈dex=9

Thanks for your help.

xsa-error.jpg (63.4 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Oct 15, 2017 at 08:07 PM

    The reason is that "/hana/shared/<you instance>/xs" folder was not deleted during uninstall XSA in my case. When I deleted that manually, the installer has been proceed successfully.

    Thanks XS advanced development support for help.

    Add comment
    10|10000 characters needed characters exceeded