Skip to Content
avatar image
Former Member

How to deactivate SPNego after running the SPNego Wizard in NW2004s

Hello,

We have a NW2004s Platform with Usage Type AS Java and DI. The SPNego is configured using the SPNego Wizard and its working absoutely fine. The problem is this that we would liek to use the Basicc authentication also side by side. In NW2004, when SPNego is manually configured (without wizard), the URL for SPNego needs to be configured so that you get the SPnego at all. If you call the normal URL for example for Portal http://portal:50000/irj, you get the Basic Authentication. But as soon as the SPNego is configured through the Wizard, the mentioned URL is automatically configured to the SPNego! During configuring the SPNego Wizard, UIDPW or Basic is set as a Fallback Authentication..but Fallback means Fallback, i.e., when SPNego doesnot function..What is when the two schemes are required to work simultaneously ?

I did change the Ticket in the Security Keystore in the Visual admin and set it to "basic" again (for the Configuration of the Wiizard, it was set to spnego) , it does return a login screen, but you cannot get acces through any of the users, not even with Administrator/j2ee_admin.

I did deactivate the service user as well, but in vain.

Has anyone experience with this. Should we make changes in the prios in the authschemes.xml ?? Would it not the working spnego in any way..

I look forward to any helpful hints.

Thanks,

Rahila Zahir

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Jan 05, 2008 at 12:14 AM

    Later I found th solution. Just had to switch back to Basic in the Login Modules in Visual Admin--Security Provider Service. I was confusing it earlier with the NW2004.

    Cheers,

    Rahila Zahir

    Edited by: Rahila Zahir on Jan 5, 2008 1:15 AM

    Add comment
    10|10000 characters needed characters exceeded