Skip to Content
avatar image
Former Member

FCC in Receiver SFTP

Hi,

Using one of the latest updates: SFTP -> SP04 Patch 36.

SFTP Receiver FCC is supported.

I'm working on this scenario with Idoc to File.

xml structure:

FCC:

The output is:
CC8898;56

The output should be:
CC8898;

Any pointers why this is not working as expected ?

Br, Martin

mt.jpg (54.3 kB)
fcc.jpg (105.8 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 02, 2017 at 04:22 PM

    if you want only batch in output, then remove the quantity from your receiver message.

    Or you can unmap the qty in message mapping.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 02, 2017 at 08:29 PM

    Hi Martin!

    This is the way FCC works in receiver adapter. It outputs all elements of recordset regardless to fieldNames parameter. So you have to remove unwanted elements from your message before its processing with FCC or MessageTransformBean.

    Regards, Evgeniy.

    Add comment
    10|10000 characters needed characters exceeded