Skip to Content
avatar image
Former Member

Edit Problem after changing and transporting a table view

Hallo Experts,

I hope you can help me.

I changed a Z-table in the Data Dictionary. For this table there exists an Tableview.

After I added three new fields I generate a new tableview:

Utilities -> table maintenance generator

Change -> create maintenance screen -> ok

after this I optimized the layout of the screen.

On our Enviromentsystem my Tableview works perfect.

I can make changes in the table.

Then I transported the new tableview to our testsystem.

There I started the sm30 "Maintain table view" and tried to change table entries.

After a click on "Maintain" the following Message appears:

TK 730 Changes to Repository or cross-client Customizing are not permitted.

The strangest thing is, that before my transport, it worked, I could change table entries.

There were no changes on the userrights.

And I can change a similar table on the testsystem.

I compared the properties of both tables. But I could not find a difference.

Have anybody an idea where the error can be?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Nov 09, 2007 at 07:50 AM

    Hi

    Caution: The table is cross-client

    Message no. TB113

    Diagnosis

    You are in the process of maintaining a cross-client table. You are using the standard table maintenance screen here, which is frequently used to maintain client-specific Customizing entries. This message serves to warn you that each change you make will have an effect on all other clients in the system.

    System response

    You have the authorization required for cross-client maintenance.

    Procedure

    Think carefully about the effect of your changes. Due to logical dependencies between client-specific Customizing and applications data on the one hand and cross-client Customizing data on the other hand, changing or deleting cross-client data could result in inconsistencies.

    Therefore such changes should be carefully planned and coordinated, taking all the clients in the system into consideration.

    Add comment
    10|10000 characters needed characters exceeded

    • That is why its giving a problem. If you keep the Recording routine as 'standard..... ' then you have to make the entries in your development system and transport the entries to further system. If you want to allow SM30 in other system also. Then you have to change the Recording routine to 'no, or -


      '.

      In that case its better to keep the CHANGE LOGS check box in the techincal settings, so that the changes made to the table are logged in the Other systems

      Regards

      Abhishek

  • avatar image
    Former Member
    Nov 09, 2007 at 11:48 PM

    Hi Mellanie,

    It is the problem with authorization. I think you dont have change authorization in the test system. check with your basis guy.

    Reward if it helps,

    Satish

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thank you for your answers.

      I found my mistake:

      Transaction sobj (Maintain View Cluster)

      In the properties of the Header Data of my table, the flag "current settings" has to be checked.

      I don´t know why this settings have changed while I created the new table view.