Skip to Content
avatar image
Former Member

BDC Error : Field BSEG-FDTAG. is not an input field: Need to press enter explicitly to save data.

BDC session method giving an error "Field BSEG-FDTAG. is not an input field", whenever im trying to upload data using bdc in tcode FB01, its a program of " CTM ". so here data is uploading properly for every posting key (28,50,1,35), but whenever there's come combination of 09 and 19 posting key, its giving error for FDTAG, and one more thing in FB01, field FDTAG and FDLEV in here im not uploading value, its system generated so ive cleared those values(this was the requirement), but now for 9 and 19 combination its not saving the uploaded data., other keys data is saving succesfully, Anyone have any idea regarding this, Ive been stuck in this issue since long. please help.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Sep 28, 2017 at 10:46 AM

    The message is clear : the field is protected. It will be confirmed if you run the session in mode 'A' (display all screens) or 'E' (display screens with error). If yes, you must reproduce manually the same inputs in FB01, and confirm to us whether the problem persists or not. If the same issue is there, then ask the "functional" people in your team, otherwise it clearly demonstrates there's a difference between real execution and batch input session, and there are many ways to change the behavior of the batch input.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Thanks for the answer, I've checked all the recordings for each posting keys,and also the FI functional guy added all the profit centre related to posting keys, so now that error for posting key 09 & 19 is not coming, but the for posting key 01 & 11 now i'm getting same error as "BSEG-FDTAG is not an input field", so to post the document using session BDC I've to explicitly click enter, then it'll save/post that entries. For 01 & 11 posting key i've done recording again and again,

      Ist - I kept FDTAG, FDLEV field as it is(which was coming from system), then by programming i cleared them ,

      2nd - I cleared FDTAG, FDLEV field at the time of recording,

      3rd - FDTAG, FDLEV field is coming from system, so in this recording i've skipped that 331 screen where FDTAG comes.

      Tried above all recordings but still i'm getting same error as "BSEG-FDTAG is not an input field".

      One more thing, at the time of recording those fields FDTAG & FDLEV are open or editable but at the time of posting entries through BDC those fields look noneditable.

      Please suggest the solution.

  • Nov 02, 2017 at 06:01 AM

    Hi Amol,

    It is better to use BAPI_ACC_DOCUMENT_POST than using BDC. With BDC, it will hit error that you are encounter. To eliminate the error that you are facing, ask your FI consultant to correct the field status setting in posting key and G/L Field Status Variant.

    Thanks.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi, I've checked the OB41 & OBC4 for posting key & for GL field status too, but there's no Planning level(BSEG-FDTAG) or Planning Date(BSEG-FDLEV), field in there in any of that group, so there's no chance to check whether its suppressed or optional or required one.

      obc4-ob41.jpg (24.3 kB)
  • Nov 02, 2017 at 08:25 AM

    By playing a batch input session, the transaction runs with the system attribute SY-BINPT set to 'X' which is often tested by the applications to display the screens differently. The features should theorically not change, but unfortunately they often do.

    To know whether the batch input would work with SY-BINPT = ' ', you may create a program to run the batch input data with the ABAP statement CALL TRANSACTION ... USING ... (aka "CTU") OPTIONS FROM ctuparams, where you set ctuparams-NOBINPT = 'X'.

    Note that you may use the program RSBTCCTU to run an existing session with CALL TRANSACTION ... USING ..., and you may tick the checkbox NOBINPT. You may find the QID parameter of the session in table APQI.

    If it works, but you want a batch input session to replay/correct the errors, unfortunately it won't work, a session always work with SY-BINPT = 'X'. But you may create your own "ZSM35" software to replay erroneous CTU (save batch input data to a custom table, create dynpros, etc.)

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 13, 2017 at 01:14 AM

    Hi Amol,

    Check OBXR, assign the planning level to the customer recon GL that you are using.

    Thanks

    Add comment
    10|10000 characters needed characters exceeded