Skip to Content
0

Cause for error regarding the server shut down at Start Instance during ECC6.0 installation?

Sep 29, 2017 at 05:39 PM

165

avatar image

Hi All,

As a part of requirement we are trying to install SAP ECC 6.0 SR3 on SUSE Linux 11.4 VM in Azure. Have a system allocated with 7GB RAM, and swap file with 21GB. The network IP is pointing to the ip to login into azure. In the etc/hosts file we have maintained the ip with the host name allocated. The problem now is that installation failed at Start Instance phase. This phase stopped with an error "Last error reported by the step : Instance reached state SHUTDOWN after having state STARTING. Giving up". The installation did not recover after that.

Could we know what could be the possible causes for the installation failure with this error. Are there tips/solutions to get past this error and complete the installation?.

Thanking You,

Regards,

Ramesh

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
Adam Gaspar
Oct 02, 2017 at 11:50 AM
1

Hello Ramesh

it looks like the messages server did not start, since nothing is answering on port 3901:

***LOG Q0I=> NiPConnect2: 10.0.0.4:3901: connect (111: Connection refused) [nixxi.cpp 3286]
*** ERROR => NiPConnect2: SiPeekPendConn failed for hdl 41/sock 15
(SI_ECONN_REFUSE/111; I4; ST; 10.0.0.4:3901) [nixxi.cpp 3286]
*** ERROR => MsIAttachEx: NiBufConnect to docs/3901 failed (rc=NIECONN_REFUSED) [msxxi.c 718]

However, since you are running in Azure, first update to an OS and SAP kernel that is supported with it, (at least SLES 12, and 7.21 EXT PL622 see note 1928533 for the details). If the same error happens with that, check the dev_ms, why the message server fails.
Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Adam,

Thank you for the suggestion. Installing on new SLES 12 SP3 for SAP. Bartosz too said to upgrade to latest kernel. Install is successful till run abap reports. There is issue with test logon failed.

Regards,

Ramesh

0
Bartosz Jarkowski Sep 30, 2017 at 11:06 AM
0

Please provide dev_disp and dev_w0 log files

Show 8 Share
10 |10000 characters needed characters left characters exceeded

Hi Bartosz,

Thank you for the above reply. Could I know what is the Bus Error. It is coming up when executing sapstartsrv with pf param pointing to our SD7_DVEBMGS00_smartdocs.

Regards,

Ramesh

0

Hi Ramesh,

Adam is correct, the dispatcher process can't connect to the message server. This can be caused due to the fact that message server is down or maybe some firewall issues.

Can you also attach the dev_ms file that I can try to find the root cause?

0

Hi Bartosz,

Thank you..Attached is the dev_ms file

Regards

Ramesh

dev-ms.txt (2.0 kB)
0

Hello again Ramesh,

I checked the log file and I was able to find the error there:

[Thr 140088504035168] *** ERROR => MsSRetClientList: MsSSend failed, rc=-1 [msxxserv_mt. 8498]

I checked in SAP notes, and the recommended solution is to update the kernel libraries.

https://blogs.sap.com/2013/08/27/step-by-step-procedure-for-kernel-up-gradation-in-windows-environment/

Please download the latest Kernel (SAPEXE and SAPEXEDB files). I believe version for ERP 6.0 is 7.22.

Let us know if that helped!

0

Hi Bartosz,

Thank you for the extended help with the link and the suggestion. Will let you know shortly.

Regards,

Ramesh

1

Ramesh, one more thing. Are you aware that you're installing a very old release of SAP ERP? If you want something more recent you should go for ERP EHP8. You wouldn't have this issue with this version

0

Hi Bartosz,

We are at the "Run ABAP Reports" phase of the SAP installation. Thank you for the above suggestions by you and Adam .Updating the kernel to 722 helped. Now the issue is have a popup "Test logon to SAP system failed" . If we click OK on the popup it is coming back again. If the cancel button is clicked will the installation stop?.Also in the background we see unable to open RFC connection messages . How to proceed further to complete the installation.

Regards,

Ramesh

1.jpg (146.4 kB)
2.jpg (182.5 kB)
0

Hello Ramesh,

that's great, thanks for letting us know! As the main question seems to be answered now, please mark the correct answer that other people can benefit :)

Regarding the issue with the logon - that's a bit suspicious. Usually, the user should log in without any problems. For now, I'd try to log in on client 066 using user DDIC and unlock the SAP* in SU01. If that won't help, please come back and we will find further steps.

0
Ramesh Jasti Oct 02, 2017 at 10:47 AM
0

Here are the files.dev-w0.txt

dev-disp.txt

Regards

Ramesh


dev-w0.txt (8.9 kB)
dev-disp.txt (57.4 kB)
Share
10 |10000 characters needed characters left characters exceeded
Ramesh Jasti Oct 02, 2017 at 12:25 PM
0
Hi Adam, Thank you for the reply...will check the note. Regards, Ramesh
Share
10 |10000 characters needed characters left characters exceeded