Skip to Content
0
Former Member
Nov 06, 2007 at 07:49 PM

BPS lock

23 Views

Hi everyone.

I'm having a problem that is confusing my mind. I tried dozens of filter configurations in planing level and in planning package, but nothing resolves a lock issue on BPS. It seems like no matter what restrictions I put on it, the entire cube data is always locked.

To try find out what could be happening, I created a simple cube, only with characteristics 0customer, 0mat_type, 0mat_group, 0calmonth and one key figure.

Then I created two planning levels, one filtering 0mat_type by value 'CA', and the other one filtering 0mat_type by value 'CS'.

After that I created one manual planing layout under each planning level. The layouts have all characteristics in lead columns.

If a user execute the layout under the first level, a second user receive the message "Data requested in planning area PL_AREA is locked by user XXX" when accessing the other layout under the other level.

Since the levels have different filters, it's not expected that one not affect the other?

I already tried to execute the report UPC_ENQUEUE_READ, but I always receive as result: __EMPTY_SELECTION__

Can anyone explain what may be happening or have any advise to solve this question?

We're in BW 3.5, SP 19.

Many thanks,

Henrique Teodoro