Skip to Content
0

Error while opening GPA tool: GnuPG is rebuilding the trust database. This might take a few seconds.

Sep 28, 2017 at 03:17 PM

438

avatar image
Former Member

Hello Folks,

I am working on a pgp encryption in HCI. I need to decrypt an incoming xml file using my private key. This file will be encrypted using the HCI public key beforehand. Now I am trying to create a public/private key combo using GnU tool. (Please bear with me I am new to this)

I go to cmd prompt (start it in admin mode) and type gpg --full-generate.

gnu-cmd1.png

I follow the steps and the keys get successfully created.

gnu-cmd2.png

I am getting errors like:

gpg: keydb search failed: provided object is too short.

So I tried using the GPA tool for creating the keys. I installed Gpg4Win along with GPA tool. restarted the system and when I start the GPA application I get 2 error boxes one on top of the other. No change after that.

1. the gpgme library returned an unexpected error at keytable.c:150. The error was: The provided object was too short. This is either an installation problem or a bug in GPA. GPA will not try to recover from this error.

gpa-error-1.png

2. GnuPG is rebuilding the trust database. This might take a few seconds.

gpa-error-2.png

I even tried Kleopatra and I am getting the same error!

Any help will be highly appreciated

Kriba

gnu-cmd1.png (19.6 kB)
gnu-cmd2.png (27.7 kB)
gpugp-folder.png (21.3 kB)
gpa-error-1.png (9.1 kB)
gpa-error-2.png (5.4 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

avatar image
Former Member Apr 09 at 06:23 AM
0

Hi Kriba,

I have been having same issues using GPG for windows. I have not figured anything out. I have tried to reinstall and cleanse computer of all traces of gpg but it comes up with same messages as you when I try to generate a key. Worked before so I am not sure what happened. Have you had any luck? Joe

Share
10 |10000 characters needed characters left characters exceeded