Skip to Content

Standard Fiori Timesheet Approval app returns error

Oct 03, 2017 at 06:05 AM


avatar image


Hi All

This is my first Fiori app for POC.

I started implementing the standard timesheet approval app and was stuck at error: (Not sure whether am following right steps)

Unable to get property ‘Container’ of undefined or null reference. fails at container property at index.html

What am trying to achieve?

Use standard front end SAP fiori timesheet approval app without any extensions with custom odata service to read our data.

What am doing:

  1. Logged into SAP fiori trial website. Under customizes and extended app I launched Web IDE in cloud by selecting timesheet approval app.
  2. It created extended project for me by importing original application.
  3. We already have HCM_TSH_APV application package downloaded in our gateway. So I have exported extension project only(ztpvextension) to my local and uploaded whole package using /UI5/UI5_REPOSITORY_LOAD program to ABAP repository. We don’t have Eclipse or local webIDE setup yet.
  4. Tried running directly from BSP applications using index.html but throughs error .( Unable to get property ‘Container’ of undefined or null reference.).
  5. We have custom odata service active and returning records as required.
  6. Created semantic object ztpvextension.

  1. Then assigned ztpvextension as application parameter and Application alias under LPD_CUST – DSS timesheet (role)
  2. Under catalogues and Groups below details were provided:


    Semantic object: ztpvextension

    Action: Approve

Target Mapping:

Application Type: SAP Fiori App using LPD_CUST

Launchpadrole: ZTIMESHEET - DSS timesheet

Application Alias: ztpvextension

Application ID: . left blank

App throughs same error if running from BSP application or from Launchpad from our gateway server after deployment.

But runs without any issue on cloud Web IDE and returns records for approvals.

Troubleshooting steps already performed:

Current SAP UI5 version we use – 1.38.6

Gateway version – 7.5 sp-level 5

Tried running with 1.38.6 AND older versions of SAP UI5 on web IDE cloud and runs without any issue.

I have attached index.html and component.js files to this email.

Please note that this is my first fiori app and any suggestions would be much appreciated.

Looks like am missing some steps.



index.html file:



<!-- Copyright (c) 2014 SAP AG, All Rights Reserved -->


<meta http-equiv="X-UA-Compatible" content="IE=edge" />

<meta http-equiv="Content-Type" content="text/html;charset=UTF-8"/>

<meta name="viewport" content="width=device-width, initial-scale=1.0" />

<title>Extension Project in UShell Sandbox</title> <script type="text/javascript">

window["sap-ushell-config"] = {

defaultRenderer : "fiorisandbox",

services: {

NavTargetResolution: {

// navigation target resolution service is configured to resolve the empty location hash to the application

config : {

resolveLocal : [ {

"linkId" : "",

resolveTo : {

additionalInformation : "SAPUI5.Component=hcm.approve.timesheet.ztpvextension",

applicationType : "URL",

url : "./" + // pass URL query parameters to application








<script src="test-resources/sap/ushell/bootstrap/sandbox.js" id="sap-ushell-bootstrap"></script>

<!--Bootstrap the UI5 core library -->

<script id="sap-ui-bootstrap"






data-sap-ui-resourceroots='{"hcm.approve.timesheet.ztpvextension": "./"}'>


<!-- Create the unified shell default renderer control and add it to the page -->

<script type="text/javascript">

sap.ui.getCore().attachInitEvent(function() {





<!-- UI Content -->

<body class="sapUiBody" id="content">



10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Kalam Angadi Nov 16, 2017 at 11:57 AM

Hi Sandeep,

I am facing the same issue when I extend standard CRM_MYTASKS app. Did you find any solution?

10 |10000 characters needed characters left characters exceeded