Skip to Content
0

Problems viewing reports that connect to Oracle database - Crystal Reports 2013

Oct 13, 2016 at 01:27 PM

710

avatar image

We installed Crystal Reports v2013 (BI 4.1 SP 2) on RedHat 6 using this installation guide. We used an external Oracle 12c database for storing CMS data. For this we installed Oracle 12c 64-bit client and created TNSNAMES.ORA with TNS entries to this database. Everything seemed to be OK and all the services were up and running. We could verify this by logging into the CMC as administrator.

We have not installed any additional drivers or clients until that moment. Then when we tried to publish a report (designed using database connection type as ‘Oracle Server’) and run the report with the option Use original database logon information from the report, but it failed. We used the option Use custom database logon information specified hereoption and filled in the DB details ourselves and selected the Oracle driver type, and it still failed. We created a TNS entry for the service name that is being referenced in the report, but without luck. This report is trying to connect to a 11g database. The database connectivity itself works without issues from the application server to the database. We verified this using telnet, tnsping and sqlplus.

We searched around for a solution and found that we also need to install a 32-bit Oracle client to run the report (as can be found here, here and a lot of other places). So we installed Oracle 12c 32 bit client and then created duplicate environment variables with 32 postfix as suggested here, here and a lot of other support tickets. Also made sure the TNSNAMES.ORA is the same for both 64-bit and 32-bit clients. But using the BOE_USE_32BIT_ENV_FORbreaks our Processing Server and the Report Application Server processes.

Attached is the report database configuration as seen on CMC rpt-db-config.jpg

Attached is the error message we see when trying to View the repor error-message.jpg

We see the following error messages in the below log files:

cr2013proc_cry02_int_oob_pp_ams.CrystalReports2013ProcessingServer_trace.000001.glf:

|e7aea1f2-bbaf-976c-f5ce-32499273c0c3|2016101015:37:23:329|+0200|Error||==|A|| cr2013proc_cry02_int_oob_pp_ams.CrystalReports2013ProcessingServer|12974|1465160144|| ||||||||||||||||||||||TraceLog::Admin: NCS Library binary is not found.

ServerWireObject.cpp:329:-: TraceLog message 2|0ad53ac5-257b-bcb4-f33a-d23f9f6752fd|2016 10 10 15:38:26:989|+0200|Error| | |E| |cr2013proc_cry02_int_oob_pp_ams.CrystalReports2013ProcessingServer|12974|1518848880|| |86|0|2|0|CMC.WebApp|cry02.int.oob.pp.ams:9989:38.62:1|crcache_cry02_int_oob_pp_ams.CrystalReportsCacheServer.post|localhost:4139:579786496.139:1|cr2013proc_cry02_int_oob_pp_ams.CrystalReports2013ProcessingServer.post|localhost:12974:1518848880.50:1|CqEtX.WJJUBTub3Tw9w_Wac3e|||||||||||ras21-core: Caught CWireObject::PropError

cr2013proc_cry02_int_oob_pp_ams.CrystalReports2013ProcessingServer_child_CRPE2_trace.000001.glf:

|d09c82e1-c1ea-c178-784b-9f246fb69784|2016101015:38:27:043|+0200|Error||==|A| |cr2013proc_cry02_int_oob_pp_ams.CrystalReports2013ProcessingServer_child_CRPE2|14570|1465160144|| ||||||||||||||||||||||TraceLog::Admin: NCS Library binary is not found.

ServerWireObject.cpp:329:-: TraceLog message 2

|1e939192-ab25-45ab-0b58-dbbd45e0b2c0|2016101015:39:21:782|+0200|Error||||E| |cr2013proc_cry02_int_oob_pp_ams.CrystalReports2013ProcessingServer_child_CRPE2|14570|1643613040|| |51|0|3|0|CMC.WebApp|cry02.int.oob.pp.ams:9989:50.92:1|cr2013proc_cry02_int_oob_pp_ams.CrystalReports2013ProcessingServer.post|localhost:12974:1522006896.98:1|cr2013proc_cry02_int_oob_pp_ams.CrystalReports2013ProcessingServer_child_CRPE2.post|localhost:14570:1643613040.7:1|CqEtX.WJJUBTub3Tw9w_Wac5c|||||||||||ras21-core: Caught CWireObject::PropError

cms_cry02_int_oob_pp_ams.CentralManagementServer_trace.000001.glf:

sessionmgr.cpp:3511:-: TraceLog message 9

|0c0a4318-232d-9690-50bb-526cec1c4e4a|2016101015:39:21:746|+0200|Error||>>|E||cms_cry02_int_oob_pp_ams.CentralManagementServer| 3882|47342493398784|| |45|0|3|0|CMC.WebApp|cry02.int.oob.pp.ams:9989:50.92:1|cr2013proc_cry02_int_oob_pp_ams.CrystalReports2013ProcessingServer.post|localhost:12974:1522006896.98:1|cms_cry02_int_oob_pp_ams.CentralManagementServer.LogonWithTokenEx5|localhost:3882:-931105024.4308:1|CqEtX.WJJUBTub3Tw9w_Wac5c|||||||||||assert failure: (sessionmgr.cpp:3511). (0 : CSessionMgr::ValidateApplicationCUID: Attempt to login when specifying

cr2013proc_cry02_int_oob_pp_ams.CrystalReports2013ProcessingServer_child_CRPE1_trace.000001.glf:

ServerWireObject.cpp:329:-: TraceLog message 3

|6374e509-2a6f-ad26-f358-4e0b3a9395d6|2016101015:39:28:747|+0200|Error|||E| |cr2013proc_cry02_int_oob_pp_ams.CrystalReports2013ProcessingServer_child_CRPE1|13079|1660607344|| |23|0|3|0|CMC.WebApp|cry02.int.oob.pp.ams:9989:51.97:1|cr2013proc_cry02_int_oob_pp_ams.CrystalReports2013ProcessingServer.post|localhost:12974:1525164912.103:1|cr2013proc_cry02_int_oob_pp_ams.CrystalReports2013ProcessingServer_child_CRPE1.post|localhost:13079:1660607344.36:1|CqEtX.WJJUBTub3Tw9w_Wac61|||||||||||ras21-core: Caught CWireObject::PropError

crcache_cry02_int_oob_pp_ams.CrystalReportsCacheServer_trace.000001.glf:

CacheObjectSharingManager.cpp:3447:-: TraceLog message 5

|7faabb6c-a365-1f29-7bbd-45f9dd6f7315|2016101015:39:28:883|+0200|Error|||E||crcache_cry02_int_oob_pp_ams.CrystalReportsCacheServer| 4139|46970342135552|| |25|0|1|0|CMC.WebApp|cry02.int.oob.pp.ams:9989:51.97:1|CMC.WebApp|cry02.int.oob.pp.ams:9989:51.97:1|crcache_cry02_int_oob_pp_ams.CrystalReportsCacheServer.post|localhost:4139:579786496.152:1|CqEtX.WJJUBTub3Tw9w_Wac61|||||||||||ras21-core: ThreadObject::Update: Failure while refreshing stage 1^^

CacheObjectSharingManager.cpp:3447:-: TraceLog message 6

|15356211-3bdc-5708-f29e-72c4d0eb3a15|2016101015:39:28:883|+0200|Error|||E||crcache_cry02_int_oob_pp_ams.CrystalReportsCacheServer| 4139|46970342135552|| |25|0|1|0|CMC.WebApp|cry02.int.oob.pp.ams:9989:51.97:1|CMC.WebApp|cry02.int.oob.pp.ams:9989:51.97:1|crcache_cry02_int_oob_pp_ams.CrystalReportsCacheServer.post|localhost:4139:579786496.152:1|CqEtX.WJJUBTub3Tw9w_Wac61|||||||||||ras21-core: ThreadObject::Update: Failure while refreshing stage 2^

The application logs though huge in number fail to give any useful information about what exactly is going wrong. Also the OCI driver seems to have been loaded as can be seen from the CMC.

Another observation is that all the libraries inside the path /export/cs2013/sap_bobj/enterprise_xi40/linux_x86/crpe are loaded except for the libcrdb_jdbc_res_en.so and libcrdb_jdbc.so (This is found by using lsof). All the environment variables seem to have been loaded and to make sure, we are also sourcing /export/cs2013/sap_bobj/setup/env.sh before starting the services.

We have the following questions:

  • 1)What are the additional configurations that we are missing for the Oracle database connectivity to work?
  • 2)How can we verify that the needed Oracle drivers are loaded on the application server?
  • 3)How can we make sure that the report uses the right drivers that are loaded, as mentioned in Question 2?
  • 4)Do you have an example template report that has example configurations for the option Use custom database logon information specified here ?
  • 5)Is there a document/KB article on how to create, configure, publish and run reports for Oracle database, from Linux?
  • 6)What drivers does the system refer to when we selected Oracle from the dropdown for the ‘Database Type’ on the ‘Database Configuration’ screen?
  • 7)Is using JDBC or ODBC connections more easy and if yes, how can we do configure them?

There seem to be a lot of confusion when it comes to connecting to Oracle database from Crystal Reports installed on Linux. Browsing through similar tickets, we saw different people proposing different solutions for seemingly the same problem. We would like to suggest you to come up with a document that could help us setup our environment within a day and get to working instead of trying to fight issues, we are not supposed to. Thank you in advance. Please let us know in case you need additional information.

rpt-db-config.jpg (80.1 kB)
error-message.jpg (29.1 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Dell Stinnett-Christy Oct 13, 2016 at 01:46 PM
0

I'm assuming that you installed Crystal Reports Server on Linux and not the Crystal Reports design tool. The server software is mostly 64-bit. However, the part that runs reports from "classic" Crystal (as opposed to Crystal for Enterprise) is still only 32-bit. So, you need to have the 32-bit Oracle client installed also. In addition, Oracle made some changes in the 12c client that make it no longer work correctly with reports created in Crystal. So, I highly recommend that you install the 32-bit 11g client and then try to publish and run the report again.

-Dell

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hello Dell,

Thank you for your response. We tried installing a 32-bit Oracle 11g driver but it complains about dependencies. So we reverted bask to 12c. To clarify, we are publishing reports from Reports Builder 2016. So, do we still need the 32 bit driver?

Also from the CMC, the 'Database Configuration' option on the report file is rather confusing. Could you please point us on how to fill the fields in that screen? How do we tell Crystal Reports to use Oracle native or JDBC or any other driver [There is a dropdown where we can choose the driver or select a Custom driver but we have no clue on how to configure this]. I attached a screen shot of this, can you please point out if there is anything wrong with this? The report was made using an Oralce OCI connection on the builder. But when we published it, it does not work. It complains that it 'failed to load database information'. Any help would be appreciated.

Regards,

John

0
Dell Stinnett-Christy Oct 15, 2016 at 07:39 PM
0

When you open the report in the designer app - Crystal Reports 2016 - you go to the Database menu. If you right-click on the database connection that the report is using and select Properties, you'll see what type of connection the report is currently using. Since you will be publishing the report to a Linux server, you can used either JDBC or Native Oracle. I highly recommend that you use the Native Oracle connection - in the @20 years that I've been using Crystal, I've had much better success with the Native connection than with any other type of connection. If your report is using another type of connection, you can go to "Set Location" on the Database menu to change the connection the report is using.

After you publish your report to the server, log in to the CMC and go to the report. Right-click and select "Database Configuration". If you have the same aliases configured in the tnsnames.ora file on both the server and the workstation where you're developing the report (even if they're pointing to different databases), all you have to do is enter the password for the database in the top section. If you need to set it to a different alias, then go to the custom configuration section and set the alias, user ID, and password. You may also need set a custom table prefix that is blank.

-Dell

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hello Dell,

Thank you for your response. The reports developer used the connection type 'Oracle Server' and tnsnames.ora for connecting to the database and it works. We then tried publishing that report and from CMC, filled the password in the top section and run the report. But we still had a problem. How can I verify if the native driver is loaded? I ask because we have a working Crystal Reports 2011 installation and when I listed the list of files loaded (using Linux command lsof) I saw that the following files (listed below) are loaded. But in the new Crystal Reports 2013, they are not loaded. Could you please confirm if these are actually the native driver files?

boe_cryst 11247 /export/cs2011/sap_bobj/enterprise_xi40/linux_x86/crpe/libcrdb_jdbc_res_en.so

boe_cryst 11247 /export/cs2011/sap_bobj/enterprise_xi40/linux_x86/crpe/libcrdb_jdbc.so

boe_crpro 12905 /export/cs2011/sap_bobj/enterprise_xi40/linux_x86/crpe/libcrdb_jdbc_res_en.so

boe_crpro 12905 /export/cs2011/sap_bobj/enterprise_xi40/linux_x86/crpe/libcrdb_jdbc.so

0