Skip to Content
avatar image
Former Member

ABAP Proxy Outbound Error

hello everybody,

i have the next scenario ABAP Proxy->XI->RFC, the problem is that in the sender system I'm getting the next error in SXMB_MONI of sender system:

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

- <!-- Call Integration Server

-->

- http://sap.com/exchange/MessageFormat">

<SAP:Context />

<SAP:Code p1="401" p2="Unauthorized" p3="" p4="">HTTP.HTTP_STATUS_CODE_NEQ_OK</SAP:Code>

<SAP:Text language="EN">HTTP status code 401 : Unauthorized</SAP:Text>

</SAP:ErrorHeader>

the status is system error, can anyone help me with this error, cause messages are not aariving to Integration Server, thanks in advance.

Regards,

Julio Cesar

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Nov 06, 2007 at 04:19 AM

    Hi Julio

    Check Following Steps:

    1:Have you insterted the correct URL of your Integration Server?

    XMB.TargetURL=http://<host>:<ICM_Port>/sap/xi/engine?type=entry

    2: Is the user and password correct?

    XMB.User=XIAPPLUSER

    XMB.Password=*****

    3: Are the read permissions in the source directory correct?

    file.sourceDir=/usr/sap/...

    4: Be sure you use the ICM Port in my case 8000, e.g.

    XMB.TargetURL=http://server:8000/sap/xi/engine?type=entry

    If you use SLD information also include

    XMD.SLDConfiguration=SLDaccessor in the file.

    Check also that the XI user has the right profiles in the XI ABAP instance.

    Thanks

    Abhishek Mahajan

    ***Reward points if helpful*********

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 05, 2007 at 11:06 PM

    Hi Julio,

    Your problem is you have no rights to send data to XI. You must provide a user and a password to you RFC connection, or maybe what you have is wrong.

    Have a look to the SM59 and execute the connection test with the connection you are using, it will give you more details about the problem.

    Hope this helps.

    Eduardo.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 06, 2007 at 02:43 AM

    Hi Julio,

    go to sxmb_adm transaction in your abap system ( not the xi system) and click on "Integration engine configuration" - In the global configuration data - U will have a field called "Corresponding Integration Server" . The value of this field will be something like dest://<RFC Destination Name>. This is the RFC destination which will be used by your applications system to connect to the integration server. So test this rfc destination. The password might have expired or changed.

    Regards,

    Arul

    PS: Reward if its useful

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi.

      what if the Corresponding Integ. Server is empty, how can vi add the configuration to the XI system and which parameters do we have to use to add The connection to XI.

      I have the problem with sending IDOC from R3 to XI , in R3 the status of idoc is sent , so maybe the sxmb_adm can help me.

      best regards.