Skip to Content
avatar image
Former Member

Error While addding a new datafile

Dear All,

We have the tablespace PSAPUSER1D in one of our production systems,which is 100% full .I am trying to extend the tablespace using brtools,but i am unable to do it and it is giving the following error.

BR0280I BRSPACE time stamp: 2007-11-05 06.55.50

BR0657I Input menu 303 - please check/enter input values

-


Options for extension of tablespace PSAPUSER1D (1. file)

1 * Last added file name (lastfile) ....... [/oracle/P01/sapdata1/psapuser1d_1.dbf]

2 * Last added file size in MB (lastsize) . [273]

3 - New file to be added (file) ........... [/oracle/P01/sapdata2/psapuser1d_1.dbf]

4 ~ Raw disk / link target (rawlink) ...... []

5 - Size of the new file in MB (size) ..... [273]

6 - File autoextend mode (autoextend) ..... [yes]

7 - Maximum file size in MB (maxsize) ..... [0]

8 - File increment size in MB (incrsize) .. [20]

9 - SQL command (command) ................. [alter tablespace PSAPUSER1D add datafile '/oracle/P01/sapdata2/psapuser1d_1.dbf' size 273M autoextend on next 20M maxsize unlimited]

Standard keys: c - cont, b - back, s - stop, r - refr, h - help

-


BR0662I Enter your choice:

c

BR0280I BRSPACE time stamp: 2007-11-05 06.55.56

BR0663I Your choice: 'c'

BR0259I Program execution will be continued...

BR1052W File psapuser1d_1.dbf is already used by the database

<u><b>BR1055E Database file /oracle/P01/sapdata2/psapuser1d_1.dbf must be located in a subdirectory of 'sapdata' directory</b>BR0669I Cannot continue due to</u> previous warnings or errors - you can go back to repeat the last action

BR0280I BRSPACE time stamp: 2007-11-05 06.55.56

BR0671I Enter 'b[ack]' to go back, 's[top]' to abort:

so please kindly give any suggestions.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Nov 05, 2007 at 01:32 PM

    Hi Balaji,

    The path you're giving to BRSPACE isn't correct. SAP expects something like "/oracle/P01/sapdata1/<b>usr_1</b>/psapuser1d_<b>1</b>.dbf", "/oracle/P01/sapdataX/<b>usr_2</b>/psapuser1d_<b>2</b>.dbf", and so on.

    and that's why is showing the error "(...)must be located in a subdirectory of 'sapdata' directory".

    Best Regards,

    JC Llanes.

    Message was edited by:

    Juan Carlos Llanes

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      To manage this, the better option is to use Oracle tools, not BR*s, p.e. Oracle Enterprise Manager (aka OEM). Sap's tools won't let you use these paths.

      You also can make it directly with sqlplus, but it's a little bit dangerous (it depends of your DBA experience).

      Best Regards,

      JC Llanes.

  • avatar image
    Former Member
    Nov 05, 2007 at 03:27 PM

    Hi Balaji,

    You can add the datafile to the same "sapdata1" as long as you call the second datafile "psapuser1d_<b>2</b>.dbf" instead of the same name "psapuser1d_<b>1</b>.dbf" in a different "sapdata".

    This should also be working using BRTools.

    Succes,

    Albert

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 06, 2007 at 12:49 PM

    I just had a similar issue this morning. Try to use sapdba tool by logging with ora<sid> of course.

    It is much more flexible than BRTools and OEM and it will give you automatically the path for the next datafile.

    Give it a try and tell us if that also has helped in your case.

    Feel free to award points if useful.

    Brgds,

    Loukas

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 06, 2007 at 03:01 PM

    Hi Balaji,

    there is no problem with adding datafiles with the same name, however some tools may object if there are any errors.

    even if you have the same filename, in the dba_data_files dictionary table, each file has its own file id and oracle doesn't write files using filenames , but uses file descriptors.

    Regards,

    Siddhesh

    Add comment
    10|10000 characters needed characters exceeded